Bug 474721 - gnome-session gets stuck in a loop
gnome-session gets stuck in a loop
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 18:52 EST by Edward Sheldrake
Modified: 2009-01-16 20:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-16 20:00:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 563354 None None None Never

  None (edit)
Description Edward Sheldrake 2008-12-04 18:52:22 EST
Description of problem:
Eventually, I cannot start any more sufficiently complex GUI programs, they hang before showing a window. When this happens gnome-session is now using 100% CPU time and the tty I ran startx from is being flooded with:

_IceTransSocketUNIXAccept: accept() failed

It seems to be caused by running qt3 programs, including uic from qt3-devel, when compiling qt3 programs.

Version-Release number of selected component (if applicable):
gnome-session-2.24.2-1.fc10.i386
qt3-3.3.8b-17.fc10.i386

How reproducible:
Always, eventually

Steps to Reproduce:
In gnome, attempt to run "uic -version" 1500 times e.g.

#!/bin/bash
for i in `seq 1 1500` ; do
uic -version
done

  
Actual results:
uic will hang after running about 1000 times, after which gnome-session will be using 100% CPU and then most other gnome programs will not start.

Expected results:
uic should execute 1500 times

Additional info:
gnome-session currently has pid 30000, and after each run of "uic -version" there's 1 more entry in /proc/30000/fd/ so eventually I guess gnome-session has too many open files.

Rebuilding and installing gnome-session-2.25.2-2.fc11.src.rpm has the same problem, with gnome-session-2.22.3-1.fc9.i386 installed in place of Fedora 10's, the problem does not occur, but of course this version does not work properly in gnome 2.24.
Comment 1 Edward Sheldrake 2008-12-05 11:45:34 EST
I did some debugging and eventually found the problem and a possible solution, added at gnome bug 563354.
Comment 2 Edward Sheldrake 2009-01-16 20:00:43 EST
The fix was included in the 2.24.3 tarball, closing.

Note You need to log in before you can comment on or make changes to this bug.