Bug 474733 - Use Network Login crashes firstboot
Use Network Login crashes firstboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 20:13 EST by Spencer Wohlers
Modified: 2008-12-12 09:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-12 09:23:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firstboot crash log (508 bytes, text/plain)
2008-12-10 18:26 EST, Spencer Wohlers
no flags Details
firstboot X logfile (33.57 KB, text/plain)
2008-12-10 18:26 EST, Spencer Wohlers
no flags Details

  None (edit)
Description Spencer Wohlers 2008-12-04 20:13:23 EST
Description of problem:

When running firstboot after installing Fedora 10 off the i686 KDE Live CD, I click the "Use Network Login..." button on the "Create User" screen and the screen goes black, leaving me just the mouse. I can't switch to another tty, and keyboard input is ignored, though I can move the cursor around.


Version-Release number of selected component (if applicable):


How reproducible:
Every time.


Steps to Reproduce:
1. Boot this Live CD: http://torrent.fedoraproject.org/torrents//Fedora-10-i686-Live-KDE.torrent
2. Install the system using the installer.
3. Reboot.
4. Continue through screens until you get to the "Create User" screen, then click "Use Network Login...".
  
Actual results:
Screen goes blank, does not recover.


Expected results:
I'm not sure. I'm going to try a different Live CD now.

Additional info:
Dell Vostro 200 on internal company network. X3000-series graphics card, I believe.
Comment 1 Chris Lumens 2008-12-09 11:06:17 EST
Afterwards, is there a /tmp/firstboot.* file available?  That file might explain what happened, though it seems to me that either X has crashed or authconfig-gtk has crashed.
Comment 2 Spencer Wohlers 2008-12-10 18:26:08 EST
Created attachment 326557 [details]
firstboot crash log
Comment 3 Spencer Wohlers 2008-12-10 18:26:45 EST
Created attachment 326558 [details]
firstboot X logfile
Comment 4 Chris Lumens 2008-12-11 13:37:57 EST
Do you have the authconfig-gtk package installed?  It looks like firstboot is missing a Requires on that package and for some reason you probably do not have it installed.  If so, just yum install it to fix the issue on your end and I'll add the Requires to make sure it's fixed for the future too.
Comment 5 Spencer Wohlers 2008-12-11 23:10:16 EST
$ rpm -q authconfig-gtk
package authconfig-gtk is not installed
Comment 6 Chris Lumens 2008-12-12 09:23:44 EST
Okay, install that package with yum and I'll make sure this is fixed in the next build of firstboot.  Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.