This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 474739 - Refresh-rate problems in Plymouth when display connected via VGA
Refresh-rate problems in Plymouth when display connected via VGA
Status: CLOSED DUPLICATE of bug 464896
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 23:14 EST by John
Modified: 2008-12-04 23:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-04 23:26:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John 2008-12-04 23:14:24 EST
Description of problem:
Hardware: ATI 9700 pro, Samsung 226CW LCD, via VGA port.
On boot, my system enters a graphical boot loader and my LCD goes nuts.  It immediately complains re resolution/refresh, and suggests changing to 1680x1050@60hz.  This happens with both the installer CD, and also my upgraded system (done via DVI port as a work-around).

When I display the current display info, it shows refresh rates of not 60hz, sometimes it's 59.5, other times it's other values.  In all cases, the display is unusable and seems to lock after a short time at this res/ref rate.

Regardless of my xorg.conf I can't get the monitor into the correct refresh rates.  I've tried custom modelines etc, but it doesn't seem to be related to X. 

This only happens with the display via VGA, and only started after F9-F10 upgrade.

A workaround is to add "nomodeset" to the boot prompt - it boots text mode, and when X starts everything works as expected now.

Version-Release number of selected component (if applicable):
plymouth-libs-0.6.0-0.2008.11.17.3.fc10.i386
plymouth-scripts-0.6.0-0.2008.11.17.3.fc10.i386
plymouth-utils-0.6.0-0.2008.11.17.3.fc10.i386
plymouth-system-plugin-0.6.0-0.2008.11.17.3.fc10.i386
plymouth-gdm-hooks-0.6.0-0.2008.11.17.3.fc10.i386
plymouth-0.6.0-0.2008.11.17.3.fc10.i386
plymouth-plugin-solar-0.6.0-0.2008.11.17.3.fc10.i386
plymouth-plugin-label-0.6.0-0.2008.11.17.3.fc10.i386


How reproducible:
Unsure.  Happens to me 100% of the time, with my HW config. I've seen multiple posts about similar issues on the forums so it seems to be happening to others too.

Steps to Reproduce:
Boot with a similar HW config.

Actual results:
Crazy monitor - goes all nuts due to incorrect refresh rate I suspect.

Expected results:
Working monitor.

Additional info:
Adding "nomodeset" to the boot prompt worked as a temp work-around.
Comment 1 John 2008-12-04 23:26:43 EST

*** This bug has been marked as a duplicate of bug 464896 ***

Note You need to log in before you can comment on or make changes to this bug.