Bug 474752 - login/logout sounds - fix or disable by default
login/logout sounds - fix or disable by default
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On: 470568
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2008-12-05 01:55 EST by Michal Hlavinka
Modified: 2009-01-26 20:50 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-26 20:50:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2008-12-05 01:55:49 EST
Description of problem:
Every time I log in (or log out) to my computer, KDE plays start sound (set by default). Every time this sound is discontinuous. It doesn't make KDE looks cool at all.

Version-Release number of selected component (if applicable):
F-10 up-to-date

How reproducible:
allways

Steps to Reproduce:
1.log in 
2.
3.
  
Actual results:
sounds are played, but it's discontinuous

Expected results:
sounds are played nicely, or not at all by default

Additional info:
in system-settings notifications these sounds are played fine
also all other notification sounds seem to be fine
Comment 1 Rex Dieter 2008-12-05 08:19:12 EST
In our testing leading up to F-10 release, it seemed to work fine for most folks.  In practice now, this problem seems to be more widespread (most likely audio driver + pa interaction, or xine-lib-pulseaudio bugs).

In light of that, I would tend to agree that login (and logout) sounds should probably be disabled by default.  That's likely something beet implemented in kde-settings.
Comment 2 Jaroslav Reznik 2008-12-05 08:40:25 EST
I (probably - our presentation laptop, so it's free for use) have access to laptop suffering this bug but really I don't know where to look. I agree, it looks like pa interaction problem to audio driver or to xine. And it occurs only in KDE.
Comment 3 Steven M. Parrish 2009-01-10 09:48:01 EST
Strange that all this worked great for me in beta but now not so great.  +1 to disabling by default.
Comment 4 Rex Dieter 2009-01-10 09:55:18 EST
retargetting rawhide/f11.
Comment 5 Kevin Kofler 2009-01-10 13:30:56 EST
I don't think sweeping the problem under the carpet is a good solution.
Comment 6 Michal Hlavinka 2009-01-26 09:32:49 EST
it seems this problem is fixed by xine-lib update xine-lib-1.1.16-1.fc10, it works for me now. I've added karma +1
Comment 7 Michal Hlavinka 2009-01-26 09:47:59 EST
(In reply to comment #6)
> it seems this problem is fixed by xine-lib update xine-lib-1.1.16-1.fc10, it

correction: it's version xine-lib-1.1.16.1-1.fc10
Comment 8 Fedora Update System 2009-01-26 20:50:13 EST
xine-lib-1.1.16.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.