Bug 474758 - Mouse loses speed settings after replugging
Mouse loses speed settings after replugging
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 455679 469744 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 03:29 EST by An. N
Modified: 2018-04-11 11:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-29 18:04:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.59 KB, text/plain)
2008-12-05 18:29 EST, An. N
no flags Details
Xorg.0.log (12.12 KB, text/plain)
2008-12-05 18:31 EST, An. N
no flags Details
Listen for DeviceAdded (in addition to the DeviceEnabled it already listens for) (869 bytes, patch)
2008-12-10 11:02 EST, Ray Strode [halfline]
no flags Details | Diff

  None (edit)
Description An. N 2008-12-05 03:29:02 EST
Description of problem:
After unplugging and re-plugging my USB mouse, the speed settings are lost (and, I presume, reset to their default values)

I use GNOME on the desktop.

Version-Release number of selected component (if applicable):
FC10 default

How reproducible:
Always

Steps to Reproduce:
1. Unplug the usb mouse
2. Plug it back in
3. 
  
Actual results:
Mouse speed is different from the one set before the unplugging took place

Expected results:
Mouse speed is the same

Additional info:
Comment 1 Matěj Cepl 2008-12-05 05:18:18 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Do you have any file in /etc/hal/fdi/policy/ ? Could we get it attached as well, please?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 An. N 2008-12-05 18:29:29 EST
Created attachment 325926 [details]
xorg.conf
Comment 3 An. N 2008-12-05 18:31:14 EST
Created attachment 325929 [details]
Xorg.0.log
Comment 4 An. N 2008-12-05 18:32:40 EST
/etc/hal/fdi/policy/ is empty.

The settings return to normal after reboot (perhaps even after logout/login - haven't tried).
Comment 5 Peter Hutterer 2008-12-07 19:24:30 EST
do you have the speed settings configured in the GNOME mouse configuration tool?
Comment 6 An. N 2008-12-09 17:38:39 EST
Yes, that's correct.
Comment 7 Peter Hutterer 2008-12-09 17:47:45 EST
Ok, this is a gnome issue then. X sees a the "virtual core pointer" (i.e. the cursor) and all physical input devices as separate devices. gnome only ever sets the speed setting on the VCP, but X is smart enough to then apply the setting to all physical devices that are attached to the VCP.

When you add a new device, it comes with the default settings. gnome doesn't yet listen to "new device" notifications, so it doesn't apply the setting again. This needs to be fixed in (upstream) gnome.
Comment 8 Ray Strode [halfline] 2008-12-10 11:02:51 EST
Created attachment 326524 [details]
Listen for DeviceAdded (in addition to the DeviceEnabled it already listens for)

I think this patch may fix the issue.

I'm building it now, and would appreciate if someone affected would test it.
Comment 9 Ray Strode [halfline] 2008-12-10 11:32:51 EST
err, will be building shortly.  I didn't properly apply the patch, and now cvs seems to be having a hickup so I can't fire off another build.
Comment 10 Fedora Update System 2008-12-10 12:27:34 EST
gnome-settings-daemon-2.24.1-6.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnome-settings-daemon-2.24.1-6.fc10
Comment 11 Fedora Update System 2008-12-11 02:56:04 EST
gnome-settings-daemon-2.24.1-7.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-settings-daemon'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11131
Comment 12 Fedora Update System 2009-01-29 18:04:08 EST
gnome-settings-daemon-2.24.1-7.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Peter Hutterer 2009-02-02 19:29:56 EST
*** Bug 469744 has been marked as a duplicate of this bug. ***
Comment 14 Bastien Nocera 2009-04-25 11:42:23 EDT
*** Bug 455679 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.