Bug 474761 - R8169 won't connect after boot
R8169 won't connect after boot
Status: CLOSED DUPLICATE of bug 460747
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 03:42 EST by An. N
Modified: 2008-12-09 16:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 16:06:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description An. N 2008-12-05 03:42:00 EST
Description of problem:
There seems to be a problem with the r8169 driver in the kernel. Often after booting it is unable to communicate with the device on the other end. Sometimes removing the r8169 module and inserting it back again helps.

The symptom when using NetworkManager is a message appearing after starting the GNOME session, saying "Network disconnected". When not using network manager and just dhclient, dhclient is trying to acquire an address but seems to receive no answer.

The network & card work perfectly fine with FC6, ms windows xp and other older systems.

Version-Release number of selected component (if applicable):
FC10 default

How reproducible:
Sometimes

Steps to Reproduce:
1. rmmod r8169
2. modprobe r8169
3. dhclient -v eth0
  
Actual results:
Can't get an address via DHCP (sending requests but "no answer")
Setting the configuration manually via ifconfig doesn't help either - the device reports network presence via mii-tool but can't seem to be able to communicate.

Expected results:
Network works fine.

Additional info:
The controller (on board):
r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
r8169 0000:03:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
r8169 0000:03:00.0: setting latency timer to 64
r8169 0000:03:00.0: no MSI. Back to INTx.
eth0: RTL8168b/8111b at 0xf883e000, 00:18:f3:43:d8:a3, XID 38000000 IRQ 19

The motherboard: asus p5b
Comment 1 An. N 2008-12-05 18:27:50 EST
I'm changing the priority to high since the kernel crashes because of this.

------------[ cut here ]------------
WARNING: at net/sched/sch_generic.c:219 dev_watchdog+0xda/0x12d()
NETDEV WATCHDOG: eth0 (r8169): transmit timed out
Modules linked in: nls_utf8 vfat fat fuse sunrpc ipv6 p4_clockmod dm_multipath uinput snd_ca0106 snd_rawmidi snd_hda_intel snd_seq_dummy snd_ac97_codec snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_hwdep snd_timer i2c_i801 ac97_bus snd_page_alloc ppdev r8169 mii snd soundcore iTCO_wdt iTCO_vendor_support nvidia(P) i2c_core pcspkr pata_jmicron parport_pc parport ata_generic pata_acpi [last unloaded: microcode]
Pid: 2880, comm: firefox Tainted: P          2.6.27.5-117.fc10.i686 #1
 [<c042bb3a>] warn_slowpath+0x4b/0x6c
 [<c0517f6d>] ? __next_cpu+0x15/0x25
 [<c0422d43>] ? find_busiest_group+0x2a8/0x716
 [<c04418d0>] ? getnstimeofday+0x3c/0xc9
 [<c043fcae>] ? ktime_get_ts+0x4a/0x4e
 [<c043fcc5>] ? ktime_get+0x13/0x2f
 [<c0430463>] ? irq_enter+0x4e/0x5a
 [<c0405e5e>] ? do_IRQ+0xe7/0xfe
 [<c051d5ec>] ? trace_hardirqs_on_thunk+0xc/0x10
 [<c0403cc3>] ? restore_nocheck_notrace+0x0/0xe
 [<c051bf6e>] ? strlcpy+0x17/0x49
 [<c063e554>] dev_watchdog+0xda/0x12d
 [<c043495a>] ? mod_timer+0x30/0x34
 [<c05d1703>] ? usb_hcd_poll_rh_status+0x125/0x12d
 [<c043046c>] ? irq_enter+0x57/0x5a
 [<c0405e00>] ? do_IRQ+0x89/0xfe
 [<c04341f5>] run_timer_softirq+0x14b/0x1bb
 [<c063e47a>] ? dev_watchdog+0x0/0x12d
 [<c063e47a>] ? dev_watchdog+0x0/0x12d
 [<c043076f>] __do_softirq+0x84/0x109
 [<c04306eb>] ? __do_softirq+0x0/0x109
 [<c0405eec>] do_softirq+0x77/0xdb
 [<c04640bb>] ? handle_fasteoi_irq+0x0/0xc0
 [<c04303d6>] irq_exit+0x44/0x83
 [<c0405e5e>] do_IRQ+0xe7/0xfe
 [<c0404654>] common_interrupt+0x28/0x30
 =======================
---[ end trace 3c7ab02471294483 ]---
r8169: eth0: link up
Comment 2 Chuck Ebbert 2008-12-08 14:37:51 EST
(In reply to comment #1)
> I'm changing the priority to high since the kernel crashes because of this.

That's not a crash, it's just a warning.
Comment 3 Chuck Ebbert 2008-12-09 16:06:40 EST

*** This bug has been marked as a duplicate of bug 460747 ***

Note You need to log in before you can comment on or make changes to this bug.