Bug 474779 - Very confusing Japanese translation
Summary: Very confusing Japanese translation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-12-05 11:47 UTC by Mamoru TASAKA
Modified: 2009-09-21 21:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-11 15:36:36 UTC
Type: ---


Attachments (Terms of Use)
patch to correct this part of translation (320 bytes, patch)
2008-12-05 11:47 UTC, Mamoru TASAKA
no flags Details | Diff

Description Mamoru TASAKA 2008-12-05 11:47:05 UTC
Created attachment 325830 [details]
patch to correct this part of translation

Description of problem:
In ja.po

--------------------------------------------------------------------
  3317  #: ../gui/system-config-selinux.glade:1547
  3318  msgid ""
  3319  "Disabled\n"
  3320  "Permissive\n"
  3321  "Enforcing\n"
  3322  msgstr ""
  3323  "許容\n"
  3324  "強制が\n"
  3325  "無効になりました\n"
--------------------------------------------------------------------

This is very confusing (and wrong) because with system-config-selinux
(in policycoreutils-gui), 
On "System Default Enforcing Mode" (in Japanese システムデフォルトの強制モード),

"Disabled" is translated into "許容" (i.e. in English "Permissive"),
"Permissive" is translated into "強制が" (in English "Enforcing mode is")
"Enforcing" is translated into "無効になりました" (in English "it got disabled")

Version-Release number of selected component (if applicable):
policycoreutils-2.0.57-11.fc10
(and also policycoreutils-2.0.60-3.fc11)

How reproducible:
100%

Steps to Reproduce:
1. launch $ system-config-selinux in ja_JP.UTF-8
2.
3.
  
Actual results:
Very confusing "System Default Enforcing Mode" appears

Expected results:
See patch attached

Additional info:
I saw this issue is report on Japanese Fedora BBS and on some blogs

Comment 1 Noriko Mizumoto 2008-12-10 02:33:45 UTC
This gives a critical impact on our end-user, since setting 'Disabled' mode actually shows up 'Permissive' and setting 'Enforcing' mode shows 'Disabled' with current release.

With the latest commit on 3-Dec, these translation has been corrected.
http://cvs.fedoraproject.org/viewvc/policycoreutils/po/ja.po?root=elvis&r1=1.24&r2=1.25

Could you please pick up revision 1.25 ja.po file and rebuild for next update?

Comment 2 Daniel Walsh 2008-12-10 14:50:36 UTC
Fixed in policycoreutils-2_0_57-14_fc10 and
policycoreutils-2.0.60-5.fc11

Comment 3 Mamoru TASAKA 2008-12-10 18:43:41 UTC
policycoreutils-2.0.60-5.fc11 seems good.

I cannot test policycoreutils-2_0_57-14_fc10 for now (I no longer
have F-10 machine and policycoreutils-2_0_57-14_fc10 cannot be installed
because F-10 uses python 2.5)

Comment 4 Mamoru TASAKA 2009-02-11 15:36:36 UTC
Closing this.


Note You need to log in before you can comment on or make changes to this bug.