Bug 474791 - Adding new Boolean Chart doesn't work as expected
Adding new Boolean Chart doesn't work as expected
Status: CLOSED UPSTREAM
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
devel
All Linux
low Severity high (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
Chris Ward
: FutureFeature
: 472041 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 07:12 EST by Chris Ward
Modified: 2013-06-23 22:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 02:48:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 337806 None None None Never
Mozilla Foundation 452434 None None None Never

  None (edit)
Description Chris Ward 2008-12-05 07:12:58 EST
Steps to Reproduce:
1. Go to Advanced query
2. Click "Add Another Boolean Query"
3. Add another Boolean Query under the first by clicking "Add Another Boolean Query" again (the same button as pushed before, not the button under the second query)
  
Actual results:
Page refreshes but there is no new boolean query. Nothing changed. Not below the first or the second existing boolean query.

Expected results:
A new boolean query would be added below the first and thus, what was the second boolean query would be made the third. 
-OR- if for some reason this is undesirable for some technical reason, then a new boolean would be added below the last boolean (not good, because then the order isn't preserved)
-OR- an error notice is provided stating WHY the new boolean couldn't be added.
Comment 1 Chris Ward 2008-12-05 07:13:47 EST
Or, i guess, remove all the 'add new boolean query' buttons that aren't going to work so we don't expect them to be functional.
Comment 2 David Lawrence 2008-12-15 11:18:31 EST
This bug has aready been reported upstream. We can work on this issue ourselves if time/resources allow.

https://bugzilla.mozilla.org/show_bug.cgi?id=337806
also
https://bugzilla.mozilla.org/show_bug.cgi?id=452434

Dave
Comment 3 David Lawrence 2008-12-15 11:24:20 EST
IMO, the "Add another boolean chart" for all charts except for the last in the list should changed to "Remove this boolean chart". Also buttons for the AND/OR lines should be added to remove just those as well.
Comment 4 David Lawrence 2008-12-15 11:24:37 EST
*** Bug 472041 has been marked as a duplicate of this bug. ***
Comment 5 Chris Ward 2010-10-07 06:09:19 EDT
Still valid since most recent upgrade to 3.6

Just load up BZ advanced query. Put first bool query. Then hit add new bool query. Then fill in those details. then hit the add new bool query underneith the first query again and the page will simply refresh without changing anything. It should, rather, bump the second query to be the third and add a new empty query as second.
Comment 6 Chris Ward 2012-02-28 06:50:06 EST
This bug is still valid in 4.2; super frustrating user experience. In fact, the 4.2 is even worse since now i can't use my browsers back button to 'undo'. 

I start to build a query... then i have to start from scratch if i realize the ordering is wrong.
Comment 7 Simon Green 2012-06-19 02:48:15 EDT
This will not be fixed in Red Hat Bugzilla. If you want it addressed, we suggest you log a bug with upstream Bugzilla ( https://bugzilla.mozilla.org/ )

  -- simon

Note You need to log in before you can comment on or make changes to this bug.