Bug 474798 - Text is not re-wrapped dynamically on terminal resize
Text is not re-wrapped dynamically on terminal resize
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 07:33 EST by An. N
Modified: 2013-09-10 15:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 14:32:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description An. N 2008-12-05 07:33:58 EST
Description of problem:
Text wrapped at column 80 (default) is not re-wrapped when the terminal is being resized. Earlier versions of Fedora supported this.

This is a major problem since if you run a command which outputs a lot of long lines, you need to run it again in order to be able to make any sense of the output in a bigger window. Previously it was possible just to resize the terminal and lines would re-wrap automatically to match the terminal width.

I'm not even sure this should be filed under termcap but it's really annoying.

Version-Release number of selected component (if applicable):
FC10 default

How reproducible:
Always

Steps to Reproduce:
1. Start gnome-terminal or xterm or rxvt
2. Run the "export" shell command for example
3. Resize the terminal by expanding it horizontally by 10 or 20 columns
  
Actual results:
Text is cut off at column 80 and continued in a new line

Expected results:
Text re-wraps dynamically as the terminal is being resized, taking advantage of extra real estate

Additional info:
The same thing happens when the terminal size is being reduced instead of expanded. Text is not being re-wrapped.
Comment 1 Miroslav Lichvar 2008-12-05 08:47:59 EST
This isn't related to termcap, it's a terminal emulator feature. I don't think xterm ever supported it, not sure about gnome-terminal. The only terminal I know that supports it is rxvt-unicode.

Which versions of Fedora supported this?
Comment 2 An. N 2008-12-05 09:43:58 EST
I think FC7 supported this in gnome-terminal, I haven't used 8 or 9 extensively. I'm not 100% sure if it was a terinal feature though, but I'm sure that I could had dynamically wrapped text i.e. when logging in remotely. In fact, the bash command line re-wraps but the text which has already "been displayed" does not re-wrap.

Where do you suggest I file this then?

Sorry for troubling you.
Comment 3 Miroslav Lichvar 2008-12-05 13:01:05 EST
Wrapping in bash command line is handled by readline, not the terminal.

Ok, let's try reassigning it to gnome-terminal.
Comment 4 Behdad Esfahbod 2008-12-05 14:32:17 EST
I'm 100% sure this never ever was implemented in gnome-terminal.  I say that because I still don't know how to implement it without shovelling the entire vte code base.

You probably piped it to less before.

Anyway, the upstream bug for this is:
http://bugzilla.gnome.org/show_bug.cgi?id=336238
Comment 5 Egmont Koblinger 2013-09-10 15:25:07 EDT
I'm making great progress in implementing rewrapping in VTE (gnome-terminal etc.). Please see the upstream bug at https://bugzilla.gnome.org/show_bug.cgi?id=336238 , feel free to try my patch if you're a hacker kind. In case of any technical feedback, please comment in that upstream bug, thanks! Hopefully my work will soon end up in mainstream VTE.

Note You need to log in before you can comment on or make changes to this bug.