Bug 474821 - SELinux warnings: inside open_file_mask_to_av with unknown mode
SELinux warnings: inside open_file_mask_to_av with unknown mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 09:34 EST by Jason Long
Modified: 2008-12-08 08:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 08:55:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Long 2008-12-05 09:34:05 EST
Description of problem:

With SELinux:targetted/permissive, I am getting hundreds of these warnings printed to the system console and to dmesg.

SELinux: WARNING: inside open_file_mask_to_av with unknown mode:c1ff

(the "c1ff" part varies between "c1ff" and "c1b6" and maybe others)


Version numbers of selected components:
selinux-policy-3.6.1-4.fc11.noarch
selinux-policy-targeted-3.6.1-4.fc11.noarch
kernel-2.6.28-0.106.rc6.git4.fc11.i686


How reproducible:
100%.
The messages occur with certain system activity. I get a LOT of these messages during startup, login, and shutdown. But I also see the messages when I run certain commands, e.g. su, rpm, "ls -l" (but not "ls").

Interesting- I get a LOT of the messages whenever I switch virtual terminals (e.g. I press Alt+F3 and I immediately see several screenfuls of these messages get printed on VT3).


Additional info:

I thought at first it was something in the NSS or PAM modules, specifically my use of nss_ldap. But I disabled nss_ldap and pam_ldap, and I still get these messages.

If SELinux is changed to "enforcing" mode, I cannot even log in.

If SELinux is changed to "disabled", I no longer see the warnings.
Comment 1 Jason Long 2008-12-08 08:33:46 EST
Good news!

This morning I pulled some more updates from Rawhide, and the warnings are no longer occurring.

Version numbers of selected components:
selinux-policy-3.6.1-6.fc11.noarch
selinux-policy-targeted-3.6.1-6.fc11.noarch
kernel-2.6.28-0.113.rc7.git5.fc11.i686

So please feel free to "resolve" this bug.
(I'd do it myself but I'm not familiar enough with policy here.)

Note You need to log in before you can comment on or make changes to this bug.