Bug 474831 - Monitor resolution tool provides no way to choose different monitor or resolution from those offered
Monitor resolution tool provides no way to choose different monitor or resolu...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 10:07 EST by Ed Avis
Modified: 2009-02-18 19:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 19:01:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2008-12-05 10:07:55 EST
(This bug is against gnome-display-properties.)

I installed Fedora 10 on a machine with an NEC LCD1701 display.  This display's native resolution is 1280x1024.  However, Fedora defaults to 1024x768.

That is not the bug per se.  The bug is that the monitor resolution tool doesn't provide any way to set the correct resolution, or an explanation of why it cannot.  The tool shows the monitor as 'NEC 17"', which is correct as far as it goes, but doesn't provide a way to enter the exact model name or to specify by hand the monitor's capabilities.

The resolution dropdown box has 1024x768, 832x624, 800x600, 640x480, and 720x400, but does not have a choice for the correct resolution and there is no way to type one in by hand.

If there is a reason why the 1280x1024 resolution cannot be selected, that reason should be displayed by the program rather than just omitting the resolution from the list.
Comment 1 Ray Strode [halfline] 2008-12-05 11:27:23 EST
The program just displays the list of available modes the X server says are available.

What type of video card do you have?

The fact it isn't working is probably an X server or driver bug.
Comment 2 Ray Strode [halfline] 2008-12-05 11:28:04 EST
Also, would you mind attaching your /var/log/Xorg.0.log and /etc/X11/xorg.conf file (if present)?
Comment 3 Matěj Cepl 2009-02-08 12:11:01 EST
Reporter, could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 4 Ed Avis 2009-02-18 06:52:27 EST
Sorry for the delay.  I have fired up the machine again, but this time it gets the correct resolution.  Perhaps some package update fixed it?  Now when I run the screen resolution tool it does include 1280x1024 in the list, where before it was missing.
Comment 5 Matěj Cepl 2009-02-18 19:01:32 EST
Cool, thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.