Bug 47486 - gdm needs an /etc/init.d/gdm file
Summary: gdm needs an /etc/init.d/gdm file
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdm   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-05 18:34 UTC by Telsa Gwynne
Modified: 2007-04-18 16:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-10 20:13:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Telsa Gwynne 2001-07-05 18:34:34 UTC
I don't normally use gdm.

But it started up after something went wrong with X setup in a text mode
install of fairfax on a laptop. I had said I didn't want X to start on
boot but it did. (already bugzilla'd.)

I wanted to get rid of it. And I can't see how to stop it short of rpm -e
or telinit 3. I expected an /etc/init.d/gdm file I could start, restart
and stop. I can't figure out how to stop it starting every time I reboot
other than removing the entire package now. Which means I can't test it
properly then :)

I don't think this is an 'enhancement'. I think it's more severe than
that. If X or gdm is broken, I have no way to stop gdm: tksysv doesn't
know about it, for example. Well, short of rpm -e which is not always
what I want.

Comment 1 Havoc Pennington 2001-07-05 19:31:31 UTC
Agree this would be nice, nontrivial though. I'll think about how to do it and
also try to convince George to do it for me. ;-)

Comment 2 Bill Nottingham 2001-07-06 03:54:33 UTC
telinit 3 is the normal way to kill a <foo>dm gone bad.

Comment 3 Havoc Pennington 2001-07-06 04:30:39 UTC
right but is there a reason why most services have scripts so you can add/remove
them from runlevels but gdm doesn't?

Comment 4 Bill Nottingham 2001-07-10 20:13:12 UTC
Because the display manager is implicitly tied to runlevel 5. Also, it wouldn't
respawn right if it was an init service (and there's a race for which console
it starts on if you do it that way.)

Comment 5 Havoc Pennington 2001-07-12 19:48:22 UTC
If Bill says it won't work then I believe him, I don't know too much about these
things.


Note You need to log in before you can comment on or make changes to this bug.