Bug 474861 - Desktop switching does not work
Desktop switching does not work
Status: CLOSED DUPLICATE of bug 204446
Product: Fedora
Classification: Fedora
Component: switchdesk (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 11:54 EST by Arvind Deshpande
Modified: 2009-05-12 04:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 04:51:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arvind Deshpande 2008-12-05 11:54:32 EST
Description of problem:switchdesk utility does not help in changing the Window Manager.


Version-Release number of selected component (if applicable):


How reproducible:Always


Steps to Reproduce:
1. Login as a normal user
2. Run switchdesk from command line by typing switchdesk GNOME or KDE
3. A UI starts up ( if switchdesk-gui RPM is installed )
4. Select the window manager that you want to change to.
5. Check the ~/.Xclients and ~/.Xclients-default to make sure that it has put in the correct window manager to be exec'ed.
6. Logout and log back in to see that your Window Manager is not changed.
  
Actual results:
Once I log back in my window Manager should have been the one I switched to but that's not the case.


Expected results:
Once I log back in my window Manager should have been the one I switched to but that's not the case.

Additional info: I haven't tried executing the window manager from .xinitrc I should probably try that one out.
2. http://forums.fedoraforum.org/showthread.php?t=205434&highlight=switchdesk See this link
Comment 1 A S Alam 2008-12-17 01:57:01 EST
I have tested and have problem with:
switchdesk-4.0.9-3.fc10.noarch

This problem also exist with Rawhide:
switchdesk-4.0.9-4.fc11.noarch
Comment 2 Matěj Cepl 2009-05-12 04:51:21 EDT

*** This bug has been marked as a duplicate of bug 204446 ***

Note You need to log in before you can comment on or make changes to this bug.