Bug 474871 - Firefox unable to find plugins when restores after KDE 4 login
Firefox unable to find plugins when restores after KDE 4 login
Status: CLOSED DUPLICATE of bug 437596
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
10
i386 Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 12:36 EST by Paul Stimpson
Modified: 2008-12-05 16:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 16:21:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 167373 None None None Never
Mozilla Foundation 262258 None None None Never

  None (edit)
Description Paul Stimpson 2008-12-05 12:36:11 EST
Description of problem:

When Firefox is started automatically as part of a KDE 4 login (because it was open when the user shut the machine down) it is unable to find any plugins.  

Version-Release number of selected component (if applicable):

firefox-3.0.4-1.fc10.i386

How reproducible:

Repeatable every time

Steps to Reproduce:
1.Open Firefox on an FC10 KDE install.
2.Open several tabs on websites then shut the machine down.
3.Restart the machine then log back in.
4.Type about:plugins into the address bar of the FF instance that automatically loads.
5.Visit a (for example) Flash enabled site to verify Flash isn't present.
6.Close FF (hitting the option to save and quit.
7.Open FF again.
8.Type about:plugins into the address bar
  
Actual results:

The first about:plugins (step 4) says that there are no plugins installed and the Flash site loaded in step 5 will show the "additional plugins required" message. The second about:plugins shows the correct plugin load and all the sites load and display correctly.

Expected results:

Plugins should be found at step 4.

Additional info:

I also had this problem on FC9.
Comment 1 Rex Dieter 2008-12-05 14:14:00 EST
Pretty much a dup of F-9's bug #437596  (I'll leave it to ff's maintainers to keep a separate F-10 bug open or mark the dup).

See also upstream bugs:
http://bugs.kde.org/show_bug.cgi?id=167373
http://bugzilla.mozilla.org/show_bug.cgi?id=262258

fact is, currently, ff's and kde4's notions of session management is incompatible.

Best/only recommendation for now is to avoid the keeping ff open on logout/shutdown.
Comment 2 Matěj Cepl 2008-12-05 16:21:08 EST

*** This bug has been marked as a duplicate of bug 437596 ***

Note You need to log in before you can comment on or make changes to this bug.