Bug 474884 - firefox 3 crashes when attempting to download files
firefox 3 crashes when attempting to download files
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Martin Stransky
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 14:09 EST by ritz
Modified: 2010-10-23 02:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 04:03:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 494542 None None None Never
Mozilla Foundation 444055 None None None Never

  None (edit)
Description ritz 2008-12-05 14:09:09 EST
Description of problem:
firefox 3 crashes when attempting to download files

Version-Release number of selected component (if applicable):
3.0.4

How reproducible:
frequent

Steps to Reproduce:
Try downloading files using ff. 
  
Actual results:
crash

Expected results:
no crash

Additional info:
possible reference - 
http://bugzilla.gnome.org/show_bug.cgi?id=494542
https://bugzilla.mozilla.org/show_bug.cgi?id=444055


backtrace

         #0  0xffffe410 in __kernel_vsyscall ()
    #1  0x00766181 in raise (sig=11)
       at ../nptl/sysdeps/unix/sysv/linux/pt-raise.c:41
    #2  0x06322656 in nsProfileLock::FatalSignalHandler (signo=11)
       at nsProfileLock.cpp:212
    #3  <signal handler called>
    #4  IA__gtk_widget_get_toplevel (widget=0x1) at gtkwidget.c:6314
    #5  0x00347704 in gtk_widget_get_screen_unchecked (widget=0x1)
       at gtkwidget.c:5699
    #6  0x00348130 in IA__gtk_widget_get_screen (widget=0x9250000)
       at gtkwidget.c:5736
    #7  0x002736dd in gtk_rc_reset_widgets (settings=0x80632e0)
       at gtkrc.c:1603
    #8  0x001fa2a1 in reset_styles_idle (user_data=0xedd03788)
       at gtkicontheme.c:600
    #9  0x009ca5e1 in g_idle_dispatch (source=0x8dd86e0, callback=0x1,
       user_data=0xedd03788) at gmain.c:3926
    #10 0x009cc342 in IA__g_main_context_dispatch (context=0x8081f08)
       at gmain.c:2045
    #11 0x009cf31f in g_main_context_iterate (context=0x8081f08, block=0,
       dispatch=1, self=0x8060fa8) at gmain.c:2677
    #12 0x009cf885 in IA__g_main_context_iteration (context=0x8081f08,
       may_block=0) at gmain.c:2736
    #13 0x06d2b665 in nsAppShell::ProcessNextNativeEvent (this=0x81ab5e8,
       mayWait=0) at nsAppShell.cpp:144
    #14 0x06d478dc in nsBaseAppShell::DoProcessNextNativeEvent
       (this=0x81ab5e8, mayWait=0) at nsBaseAppShell.cpp:151
    #15 0x06d47db4 in nsBaseAppShell::OnProcessNextEvent (this=0x81ab5e8,
       thr=0x80a99f0, mayWait=0, recursionDepth=1) at nsBaseAppShell.cpp:278
    #16 0x06e58bb0 in nsThread::ProcessNextEvent (this=0x80a99f0, mayWait=0,
       result=0xffff7e48) at nsThread.cpp:497
    #17 0x06e17407 in NS_ProcessPendingEvents_P (thread=0x80a99f0, timeout=20)
       at nsThreadUtils.cpp:180
    #18 0x06d47b07 in nsBaseAppShell::NativeEventCallback (this=0x81ab5e8)
       at nsBaseAppShell.cpp:121
    #19 0x06d2b8fc in nsAppShell::EventProcessorCallback (source=0x811fc30,
       condition=G_IO_IN, data=0x81ab5e8) at nsAppShell.cpp:69
    #20 0x009f594d in g_io_unix_dispatch (source=0x8122370,
       callback=0x6d2b8c0 <nsAppShell::EventProcessorCallback(_GIOChannel*,
       GIOCondition, void*)>, user_data=0x81ab5e8) at giounix.c:162
    #21 0x009cc342 in IA__g_main_context_dispatch (context=0x8081f08)
       at gmain.c:2045
    #22 0x009cf31f in g_main_context_iterate (context=0x8081f08, block=1,
       dispatch=1, self=0x8060fa8) at gmain.c:2677
    #23 0x009cf6c9 in IA__g_main_loop_run (loop=0x9152f58) at gmain.c:2881
    #24 0x001ac9eb in IA__gtk_dialog_run (dialog=0xf5e040e0)
       at gtkdialog.c:996
    #25 0x06d3dc9f in RunDialog (aDialog=0xf5e040e0)
       at nsAccessibilityHelper.cpp:52
    #26 0x06d372a5 in nsFilePicker::Show (this=0xe8bb4fb8, aReturn=0xffff8234)
       at nsFilePicker.cpp:661
    #27 0x06e69579 in NS_InvokeByIndex_P ()
       at ../dist/include/xpcom/nsCOMPtr.h:713
    #28 0x063543c5 in XPCWrappedNative::CallMethod (ccx=@0xffff8408,
       mode=XPCWrappedNative::CALL_METHOD) at xpcwrappednative.cpp:2393
    #29 0x0635b2ea in XPC_WN_CallMethod (cx=0x81f7250, obj=0x8d09d40, argc=0,
       argv=0xf5e9bd4c, vp=0xffff8538) at xpcwrappednativejsops.cpp:1473
    #30 0x04e2116a in js_Invoke (cx=0x81f7250, argc=0, vp=0xf5e9bd44, flags=0)
       at jsinterp.c:1297
    #31 0x04e14f5d in js_Interpret (cx=0x81f7250) at jsinterp.c:4852
    #32 0x04e2129a in js_Invoke (cx=0x81f7250, argc=5, vp=0xf5e9bcfc, flags=0)
       at jsinterp.c:1313
    #33 0x06350a0c in nsXPCWrappedJSClass::CallMethod (this=0xe8ab4d78,
       wrapper=0xf60b9ec0, methodIndex=4, info=0xf278e670,
       nativeParams=0xffff8b64) at xpcwrappedjsclass.cpp:1523
    #34 0x0634a5f3 in nsXPCWrappedJS::CallMethod (this=0xf60b9ec0,
       methodIndex=4, info=0xf278e670, params=0xffff8b64)
       at xpcwrappedjs.cpp:559
    #35 0x06e6a11b in PrepareAndDispatch (methodIndex=<value optimized out>,
       self=0xe9a676f8, args=0xffff8c1c) at xptcstubs_gcc_x86_unix.cpp:95
    #36 0x06ad4aee in nsExternalAppHandler::PromptForSaveToFile
       (this=0xe9b3b668, aNewFile=0xffff8eac, aDefaultFile=@0xe9b3b6a0,
       aFileExtension=@0xffff8cc0)
       at nsExternalHelperAppService.cpp:1920
    #37 0x06ad80e3 in nsExternalAppHandler::SaveToDisk (this=0xe9b3b668,
       aNewFileLocation=0x0, aRememberThisPreference=0)
       at nsExternalHelperAppService.cpp:2015
    #38 0x06e69579 in NS_InvokeByIndex_P ()
        at ../dist/include/xpcom/nsCOMPtr.h:713
    #39 0x063543c5 in XPCWrappedNative::CallMethod (ccx=@0xffff9194,
       mode=XPCWrappedNative::CALL_METHOD) at xpcwrappednative.cpp:2393
    #40 0x0635b2ea in XPC_WN_CallMethod (cx=0x81f7250, obj=0xebc7f960, argc=2,
       argv=0xf5e9bcec, vp=0xffff92c4) at xpcwrappednativejsops.cpp:1473
    #41 0x04e2116a in js_Invoke (cx=0x81f7250, argc=2, vp=0xf5e9bce4, flags=0)
       at jsinterp.c:1297
    #42 0x04e14f5d in js_Interpret (cx=0x81f7250) at jsinterp.c:4852
    #43 0x04e2129a in js_Invoke (cx=0x81f7250, argc=1, vp=0xf5e9bcd8, flags=0)
       at jsinterp.c:1313
    #44 0x06350a0c in nsXPCWrappedJSClass::CallMethod (this=0x8427c20,
       wrapper=0xf5eedfb0, methodIndex=3, info=0xf4c06ab8,
       nativeParams=0xffff98f0) at xpcwrappedjsclass.cpp:1523
    #45 0x0634a5f3 in nsXPCWrappedJS::CallMethod (this=0xf5eedfb0,
       methodIndex=3, info=0xf4c06ab8, params=0xffff98f0)
       at xpcwrappedjs.cpp:559
    #46 0x06e6a11b in PrepareAndDispatch (methodIndex=<value optimized out>,
       self=0xf29511a8, args=0xffff9994) at xptcstubs_gcc_x86_unix.cpp:95
    #47 0x06e5c669 in nsTimerImpl::Fire (this=0xe62eefb0)
       at nsTimerImpl.cpp:403
    #48 0x06e5c76e in nsTimerEvent::Run (this=0xf1c01200)
       at nsTimerImpl.cpp:490
    #49 0x06e58c0f in nsThread::ProcessNextEvent (this=0x80a99f0, mayWait=1,
       result=0xffff9a54) at nsThread.cpp:510
    #50 0x06e17343 in NS_ProcessNextEvent_P (thread=0x60103, mayWait=1)
       at nsThreadUtils.cpp:227
    #51 0x06d47a67 in nsBaseAppShell::Run (this=0x81ab5e8)
       at nsBaseAppShell.cpp:170
    #52 0x06b4debf in nsAppStartup::Run (this=0x81f6e08)
       at nsAppStartup.cpp:181
    #53 0x0631a231 in XRE_main (argc=1, argv=0xffffd224, aAppData=0x8060980)
       at nsAppRunner.cpp:3170
    #54 0x080490a2 in __gxx_personality_v0 ()
       at libstdc++-v3/libsupc++/eh_personality.cc:349
    #55 0x005fadec in __libc_start_main (
       main=0x8048d50 <__gxx_personality_v0+352>, argc=1, ubp_av=0xffffd224,
       init=0x804f820 <__gxx_personality_v0+27696>,
       fini=0x804f810 <__gxx_personality_v0+27680>,
       rtld_fini=0x5d55d0 <_dl_fini>, stack_end=0xffffd21c)
       at libc-start.c:231
    #56 0x08048c51 in __gxx_personality_v0 ()
       at libstdc++-v3/libsupc++/eh_personality.cc:349
Comment 1 Matěj Cepl 2008-12-05 16:23:29 EST
Cannot reproduce here...
Comment 2 Matěj Cepl 2008-12-05 16:29:10 EST
I cannot reproduce here, so let's round up usual suspects:

1) are you able to reproduce the problem while running in safe mode (run with the command line option -safe-mode)? If no, then I would suspect some plugin malfunctioning,
2) are you able to reproduce with the upstream binary from www.mozilla.com?
3) do you have something interesting going on? (/home on NFS share, 64bit system, ...)

Thank you for any reply.
Comment 3 Matěj Cepl 2009-02-08 12:13:12 EST
Reporter, could you please reply to the previous question? Thank you.
Comment 5 Matěj Cepl 2009-03-26 18:41:03 EDT
Possible duplicates are bug 491086 and bug 449965
Comment 6 Martin Stransky 2009-04-01 04:03:09 EDT
Unable to reproduce, closing as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.