Bug 474891 - PCI Domain support for HP xw9400 and xw9300
PCI Domain support for HP xw9400 and xw9300
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
high Severity high
: rc
: 5.4
Assigned To: Prarit Bhargava
Red Hat Kernel QE team
:
Depends On:
Blocks: 483701
  Show dependency treegraph
 
Reported: 2008-12-05 14:58 EST by Prarit Bhargava
Modified: 2009-02-20 12:44 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 12:44:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL5 fix for this issue (1.35 KB, patch)
2008-12-08 08:55 EST, Prarit Bhargava
no flags Details | Diff
Output for lspci -D on the -128 kernel (2.37 KB, text/plain)
2009-02-04 11:19 EST, Steve Cormack
no flags Details
Output for lspci -D on the -129 kernel (2.37 KB, text/plain)
2009-02-04 11:21 EST, Steve Cormack
no flags Details
Output for lspci -D on the -130 kernel (2.37 KB, text/plain)
2009-02-06 11:21 EST, Steve Cormack
no flags Details

  None (edit)
Description Prarit Bhargava 2008-12-05 14:58:47 EST
Description of problem:

xw9400 and xw9300 systems blacklisted for PCI Domain support.  This was done at a time when PCI Domain support was not enabled in RHEL5 and these systems did not boot because of the extra domain.

Version-Release number of selected component (if applicable): -125.el5


How reproducible: 100%


Steps to Reproduce:
1. Boot
2. lspci -D
3.
  
Actual results: lspci -D output shows single domain.


Expected results: lspci -D output should show two.


Additional info: Noticed by tcamuso, onsite engineer for HP.
Comment 1 Prarit Bhargava 2008-12-08 08:55:38 EST
Created attachment 326131 [details]
RHEL5 fix for this issue
Comment 2 Tony Camuso 2008-12-10 06:15:10 EST
Prarit tested his PCI domain patch on these systems by removing them from the blacklist. 

However, HP feels that we are too close to the end of the 5.3 cycle to make this change and get adequate test exposure before the GA date, so we would like to defer the fix to 5.4.
Comment 3 RHEL Product and Program Management 2009-01-27 15:40:03 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Don Zickus 2009-02-02 14:47:48 EST
in kernel-2.6.18-130.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 5 Steve Cormack 2009-02-04 11:19:21 EST
Created attachment 330880 [details]
Output for lspci -D on the -128 kernel

attached a text file with the output after running lspci -D on the 2.6.18-128 kernel
Comment 6 Steve Cormack 2009-02-04 11:21:31 EST
Created attachment 330881 [details]
Output for lspci -D on the -129 kernel 

Attached a text file with the output after running lspci -D on the 2.6.18-129 kernel.  I do not see a difference in the text file 128kernel.txt when running a diff againest the 129kernel.txt file.  Is this expected behavior?
Comment 7 Prarit Bhargava 2009-02-04 11:29:29 EST
(In reply to comment #6)
> Created an attachment (id=330881) [details]
> Output for lspci -D on the -129 kernel 
> 
> Attached a text file with the output after running lspci -D on the 2.6.18-129
> kernel.  I do not see a difference in the text file 128kernel.txt when running
> a diff againest the 129kernel.txt file.  Is this expected behavior?

This wasn't committed to a kernel until -130.el5 .

P.
Comment 8 Steve Cormack 2009-02-06 11:21:29 EST
Created attachment 331140 [details]
Output for lspci -D on the -130 kernel

I'm assuming this is now fixed since I was able to boot with the -130 kernel with AHCI Bus Segmentation enabled.
Comment 9 Tony Camuso 2009-02-09 09:05:54 EST
Yes, I believe it is fixed and this BZ can be closed.
Comment 10 RHEL Product and Program Management 2009-02-16 10:22:27 EST
Updating PM score.

Note You need to log in before you can comment on or make changes to this bug.