This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 4749 - Kickstart
Kickstart
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-27 11:24 EDT by muammer.arslan
Modified: 2015-01-07 18:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-08 07:37:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description muammer.arslan 1999-08-27 11:24:27 EDT
Hi,

There is  a problem with  Kickstart in combination with
"xconfig". The Kickstart installation process runs until it
starts  4xconfig'. On the xconfig section the automatic
process is interrupted and returns to manual mode (I think
it can't detect the monitor type or graphic card. I don't
know exactly). If I select the monitor type VGA Ramsize
etc. it doesn't go back to the kickstart installation
process. The installation process only shows the message,
that it was a successful installation.
But there is  still  a lot to do left in the  %post section
(but this part seems to be totally ignored).

I expand the Kickstartfile as follows:
"ks.cfg" the "xconfig" parameters with my VGA Card
information. I tried to use for example

xconfig --card "ELSA Winner 2000/Office" --monitor
"Generic01" --server "3DLabs" or
xconfig --card "ELSA Winner 2000/Office" --monitor "Sony
CPD-100ES" --server "3DLabs"  or
xconfig --card "ELSA Winner 2000/Office" --monitor "Sony
CPD-100ES"
xconfig --server "3DLabs" --monitor "Sony CPD-100ES"

but I had no success.

When the manual process starts it is detecting the card
automatically I put in the Kickstart-file.
I can`t  understand it.

I think, that is a bug in the installation-script.   Why
does the kickstart process abort after the x-Window
configuration?
We would like to use  the kickstart installation process
for automatic software distribution. It would make life for
us a lot easier. We must install many PC's with the same
configuration. We are a educational center and sometimes
participants do strange things to the PCs.

I sent this Problem to Martin Hamilton (the writer of the
kickstart-HOWTO too and he answered as follows:

"I think you'll find that most forms of manual intervention
cause the Kickstart process to terminate, so you go back to
manual install again."


Any help would be appreciated.

Many thanks for a quick answer in advance. :-)

Muammer Arslan
Comment 1 Jay Turner 2000-02-08 07:37:59 EST
There are several issues with the kickstart code handling in release 6.0 as well
as 6.1 or Red Hat Linux.  You can certainly try release 6.1 and see if that
solves your problem, but you will probably want to take a look at the latest
RawHide and see if they fix your problem.  There has been a lot of work
completed on kickstart during development of the new release.

Please reopen this bug if you continue to have problems.

Note You need to log in before you can comment on or make changes to this bug.