Bug 474901 - Network manager does not work when aliases created
Network manager does not work when aliases created
Status: CLOSED DUPLICATE of bug 443968
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 16:07 EST by Need Real Name
Modified: 2009-02-13 07:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 07:32:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2008-12-05 16:07:23 EST
After I created eth0:1 alias interface with a fixed IP 
NetworkManager stopped working at all.
The only way to start network now - 
ifup eth0
eth0 - is set via DHCP.

also, ifup command give some errors sometimes.
Comment 1 Need Real Name 2008-12-05 20:18:11 EST
when requesting DHCP

[root@mobile ~]# ifup eth0

Determining IP information for eth0...Nothing to flush.
ipcalc: netmask or prefix expected
Usage: ipcalc [OPTION...]
  -b, --broadcast     Display calculated broadcast address
  -h, --hostname      Show hostname determined via DNS
  -m, --netmask       Display default netmask for IP (class A, B, or C)
  -n, --network       Display network address
  -p, --prefix        Display network prefix
  -s, --silent        Don't ever display error messages 

Help options:
  -?, --help          Show this help message
  --usage             Display brief usage message
Nothing to flush.
Nothing to flush.
 done.
[root@mobile ~]# 

cat /var/log/audit/audit.log |audit2allow 


#============= NetworkManager_t ==============
allow NetworkManager_t dhcpc_state_t:dir search;

#============= dhcpc_t ==============
allow dhcpc_t unconfined_t:unix_stream_socket { read write };

#============= nsplugin_t ==============
allow nsplugin_t admin_home_t:dir search;
allow nsplugin_t admin_home_t:file { write read };

#============= setfiles_t ==============
allow setfiles_t unconfined_t:unix_stream_socket { read write };
Comment 2 Need Real Name 2008-12-05 20:18:45 EST
 sh -x ifup eth0
+ unset WINDOW
+ . /etc/init.d/functions
++ TEXTDOMAIN=initscripts
++ umask 022
++ PATH=/sbin:/usr/sbin:/bin:/usr/bin
++ export PATH
++ '[' -z '' ']'
++ COLUMNS=80
++ '[' -z '' ']'
+++ /sbin/consoletype
++ CONSOLETYPE=pty
++ '[' -f /etc/sysconfig/i18n -a -z '' -a -z '' ']'
++ . /etc/profile.d/lang.sh
+++ sourced=0
+++ '[' -n en_US.UTF-8 ']'
+++ saved_lang=en_US.UTF-8
+++ '[' -f /root/.i18n ']'
+++ LANG=en_US.UTF-8
+++ unset saved_lang
+++ '[' 0 = 1 ']'
+++ unset sourced
+++ unset langfile
++ unset LANGSH_SOURCED
++ '[' -z '' ']'
++ '[' -f /etc/sysconfig/init ']'
++ . /etc/sysconfig/init
+++ BOOTUP=color
+++ RES_COL=60
+++ MOVE_TO_COL='echo -en \033[60G'
+++ SETCOLOR_SUCCESS='echo -en \033[0;32m'
+++ SETCOLOR_FAILURE='echo -en \033[0;31m'
+++ SETCOLOR_WARNING='echo -en \033[0;33m'
+++ SETCOLOR_NORMAL='echo -en \033[0;39m'
+++ LOGLEVEL=3
+++ PROMPT=yes
+++ AUTOSWAP=no
++ '[' pty = serial ']'
++ __sed_discard_ignored_files='/\(~\|\.bak\|\.orig\|\.rpmnew\|\.rpmorig\|\.rpmsave\)$/d'
+ cd /etc/sysconfig/network-scripts
+ . ./network-functions
++ PATH=/sbin:/usr/sbin:/bin:/usr/bin
++ export PATH
++ '[' -z '/\(~\|\.bak\|\.orig\|\.rpmnew\|\.rpmorig\|\.rpmsave\)$/d' ']'
+ '[' -f ../network ']'
+ . ../network
++ NETWORKING=yes
++ HOSTNAME=mobile
+ CONFIG=eth0
+ '[' -z eth0 ']'
+ need_config eth0
+ local nconfig
+ CONFIG=ifcfg-eth0
+ '[' -f ifcfg-eth0 ']'
+ return
+ '[' -f ifcfg-eth0 ']'
+ '[' 0 '!=' 0 ']'
+ source_config
++ basename ifcfg-eth0
++ sed 's/^ifcfg-//g'
+ DEVNAME=eth0
+ echo ifcfg-eth0
+ grep -q '[^g]-'
+ . ifcfg-eth0
++ DEVICE=eth0
++ HWADDR=00:14:c2:d7:8a:6e
++ ONBOOT=no
++ BOOTPROTO=dhcp
++ USERCTL=no
++ IPV6INIT=no
++ NM_CONTROLLED=no
++ TYPE=Ethernet
+ '[' -r keys-eth0 ']'
+ case "$TYPE" in
+ DEVICETYPE=eth
+ '[' -z eth ']'
+ '[' -z '' -a -n '' ']'
+ '[' -z '' ']'
+ REALDEVICE=eth0
+ '[' eth0 '!=' eth0 ']'
+ ISALIAS=no
+ '[' -n 00:14:c2:d7:8a:6e ']'
++ echo 00:14:c2:d7:8a:6e
++ awk '{ print toupper($0) }'
+ HWADDR=00:14:C2:D7:8A:6E
+ '[' -n '' ']'
+ '[' foo = fooboot ']'
+ '[' -n '' ']'
+ '[' -n '' -a Ethernet = Bridge ']'
+ '[' -x /sbin/vconfig -a '' = yes -a no = no ']'
+ '[' '' = yes ']'
+ '[' dhcp = bootp -o dhcp = dhcp ']'
+ DYNCONFIG=true
+ '[' -x /sbin/ifup-pre-local ']'
+ OTHERSCRIPT=/etc/sysconfig/network-scripts/ifup-eth
+ '[' '!' -x /etc/sysconfig/network-scripts/ifup-eth ']'
+ exec /etc/sysconfig/network-scripts/ifup-eth ifcfg-eth0

Determining IP information for eth0...Nothing to flush.
ipcalc: netmask or prefix expected
Usage: ipcalc [OPTION...]
  -b, --broadcast     Display calculated broadcast address
  -h, --hostname      Show hostname determined via DNS
  -m, --netmask       Display default netmask for IP (class A, B, or C)
  -n, --network       Display network address
  -p, --prefix        Display network prefix
  -s, --silent        Don't ever display error messages 

Help options:
  -?, --help          Show this help message
  --usage             Display brief usage message
Nothing to flush.
Nothing to flush.
 done.
[root@mobile ~]#
Comment 3 Dan Williams 2009-02-13 07:32:43 EST

*** This bug has been marked as a duplicate of bug 443968 ***

Note You need to log in before you can comment on or make changes to this bug.