Bug 474916 - Locale not set to en_IN even after selecting "English (India)"
Locale not set to en_IN even after selecting "English (India)"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 16:43 EST by Rohan Dhruva
Modified: 2008-12-08 02:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 02:05:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rohan Dhruva 2008-12-05 16:43:16 EST
Description of problem:
I installed Fedora 10 using the gnome livecd. While installation I selected the time zone as "Asia/Calcutta", and keyboard layout as US English. The installed system shows the output of locale as en_US.UTF8. Thinking that it must be some quirk, I used system-config-language and set the system language to "English (India)". However, even after rebooting, the output of locale remains en_US.UTF8. s-c-l shows the language set to "English (India)" even after reboot, but "locale" does not concur.

Version-Release number of selected component (if applicable):
system-config-language-1.3.2-3.fc10.noarch

How reproducible:
Always

Steps to Reproduce:
1. Open s-c-l
2. Set language to "English (India)"
  
Actual results:
After reboot, all fields of locale still show en_US

Expected results:
They should show en_IN

Additional info:
Here is the output of locale:

[rohan@fedora sysconfig]$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

and some more useful output:
[rohan@fedora ~]$ cat /etc/sysconfig/i18n 
LANG="en_IN.UTF-8"
SYSFONT="latarcyrheb-sun16"
[rohan@fedora ~]$ cat /etc/environment 
[rohan@fedora ~]$
Comment 1 Pravin Satpute 2008-12-08 00:54:09 EST
Hi Rohan,
[rohan@fedora ~]$ cat /etc/sysconfig/i18n 
LANG="en_IN.UTF-8"
It means s-c-l has doing its job

  can you try same once again, while login check the gdm selection i think it is still showing English(United States) and overriding s-c-l setting, change it to required and then try.
Comment 2 Rohan Dhruva 2008-12-08 01:49:00 EST
Thanks a lot, Pravin. The problem was indeed with GDM overriding my language preference. This resolves the bug :) Will you please help me in marking this bug as resolved?
Comment 3 Pravin Satpute 2008-12-08 02:05:04 EST
You are Welcome !!

Note You need to log in before you can comment on or make changes to this bug.