Bug 474948 - Fedora 10 freezes after a while (< 6 hours)
Fedora 10 freezes after a while (< 6 hours)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 19:21 EST by Ranjan Maitra
Modified: 2009-10-16 07:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 488395 (view as bug list)
Environment:
Last Closed: 2009-10-16 07:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log attached (91.59 KB, text/plain)
2008-12-05 19:21 EST, Ranjan Maitra
no flags Details
/etc/X11/xorg.conf (588 bytes, text/plain)
2008-12-05 19:23 EST, Ranjan Maitra
no flags Details
output from glxinfo (5.41 KB, text/plain)
2008-12-07 11:28 EST, Ranjan Maitra
no flags Details

  None (edit)
Description Ranjan Maitra 2008-12-05 19:21:42 EST
Created attachment 325949 [details]
Xorg.0.log attached

Description of problem:

My Fedora 10 upgraded (from F9) installation on my Dell Precision 650 with  ATI Technologies Radeon R300 NG (FireGL X1) graphics card freezes after about six hours. I thought this may be due to the kernel modesetting so I set nomodeset at the end of the line when I booted. (Even though I wondered about the problem given that I do not have the compiz installed. I have looked at /var/log/messages, /var/log/secure, no luck. I am running 

% uname -a 
Linux 2.6.27.5-117.fc10.i686 #1 SMP Tue Nov 18 12:19:59 EST 2008 i686 i686 i386 GNU/Linux

There are two CPU's Intel(R) Xeon(TM) CPU 3.06GHz

I have also tried setting up no rhgb at boot but still no luck. 

My system is completely up to date: all components are updated to the latest released by Fedora.

Version-Release number of selected component (if applicable):



How reproducible:

Everytime

Steps to Reproduce:
1. Boot into system (with/without nomodeset, with/without rhgb)
2. Work 
3. Goof-off
  
Actual results:

The entire machine freezes after a long while. A hard boot (a la Windoze) is needed. The machine's fan is on at full speed after a while.

Expected results:

The machine should continue to work normally.

Additional info:

I am attaching Xorg.0.log as well as xorg.conf. These are obviously after the reboot (since I am frozen out). Please let me know what else I can provide.
Comment 1 Ranjan Maitra 2008-12-05 19:23:28 EST
Created attachment 325950 [details]
/etc/X11/xorg.conf
Comment 2 Ranjan Maitra 2008-12-05 19:24:39 EST
Please note that this appears different from the (similar) problem also reported: which seems to be that there is a problem introduced by kernel modesetting. Setting nomodeset seems to have ABSOLUTELY no effect.
Comment 3 Ranjan Maitra 2008-12-07 11:28:55 EST
Created attachment 326045 [details]
output from glxinfo

I have noticed that for me (running without rhgb quiet and with nomodeset), it does not freeze (after 40 hours) when i use xlock -mode blank. Based on someone's observation on the mailing list, it appears that glxgears may have something to do with it. So I am including the output of my glxinfo in hopes that it may be useful.
Comment 4 Benny 2009-02-15 15:30:01 EST
Same problem on a HP Pavilion Slimline with AMD Athlon 64 X2 and a NVIDIA GeForce 7300 (with third-party closed source Nvidia drivers from RPM fusion) computer just freezes randomly while working on it, and the power button is the only solution...
running without rhgb and with quiet nomodeset.
Comment 5 Christos P. Sotiriou 2009-03-01 01:20:44 EST
I am using a GeForce 9800GT and I am also getting random freezes, however only while xscreensaver is running.

I have the latest NVidia drivers 180.29 (64-bit) and an fully-updated machine. Is my issue unrelated, as the bug component is xorg-x11-drv-ati?

I have tested my memory and cannot find anything hardware related to be wrong with my machine. 

Can you post some additional specific information about how this bug is manifested?

Thanks.
Comment 6 Christos P. Sotiriou 2009-03-02 05:34:23 EST
I refrained from using xscreensaver (used xlockmore instead) and my box is running stable for 1 day and 5 hours...

I am using xscreensaver-base-5.08-5.fc10.x86_64 ...

and NVidia 180.29 drivers.

I am becoming certain that this is an xscreensaver issue (at least for me). Please let me know if you need any specific information.
Comment 7 Benny 2009-03-02 05:49:12 EST
For me, I'm sure it is not a xscreensaver bug since its not installed and I experienced freezes while using firefox...
Comment 8 Christos P. Sotiriou 2009-03-02 06:04:24 EST
Unfortunately you are right. 

My machine froze 10mins ago... I rushed the email it seems.

I would really appreciate for Redhat support to look at this. It is really unacceptable that the machine freezes using a "standard distribution".

I using an NVidia Card, so I am not even sure it's ATI related.

Thank you.
Comment 9 Christos P. Sotiriou 2009-03-02 06:09:46 EST
Why is the Priority of this bug Low Anyway? 

A machine freeze is not a minor functional issue?

What is the workaround?
Comment 10 Christos P. Sotiriou 2009-03-02 08:17:24 EST
This thread is also related to this bug:

http://forums.fedoraforum.org/showthread.php?t=205950&page=6
Comment 11 Benny 2009-03-02 14:59:06 EST
As a work around some try:
- noapic
others try: 
- acpi=off 
In the kernel command line (grub.conf)
But no definite work around known at the moment... af far as I know
Comment 12 Christos P. Sotiriou 2009-03-02 16:24:47 EST
Thanks!

I tried noapic, as suggested in the fedoraforum thread, however I still got the same behaviour, i.e. sporadic, random freezes, particularly while the system was idling.

I am now trying out acpi=off, as I suspected it was ACPI related. 

I will report back about its behaviour.
Comment 13 Christos P. Sotiriou 2009-03-03 12:01:24 EST
acpi=off yields the same behavior.

I also updated my BIOS and my machine today to 2.6.27.19-170.2.35.fc10.x86_64
and I am still getting the same problem.

Is any maintainer interested in this problem or should we all just switch to Ubuntu/Gentoo, etc? (or even windows)...

Please let us know why this is taking so long and there are no signs of interest from the Fedora/Redhat Teams.

Some related threads which illustrate the # of affected users:
http://forums.fedoraforum.org/showthread.php?t=205950&page=7
http://forums.fedoraforum.org/showthread.php?t=210571&highlight=nvidia&page=3
http://forums.fedoraforum.org/showthread.php?p=1176172&posted=1#post1176172
Comment 14 MuadNu 2009-03-03 12:25:26 EST
Same issue here on a Dell Vostro 1400. The noapic fix is maybe working, I've had only one freeze in 4 or 5 days, though I don't know if it was due to this issue or something different.
Comment 15 Ranjan Maitra 2009-03-03 13:47:56 EST
I agree with the frustration expressed by a previous poster: why is the priority so low for this important bug. It also appears strange that the assignee has never commented or asked for information: I wonder if he is even aware. That said, it appears that in my case, glxgears was the culprit. Getting rid of it (glx-utils rpm) has got rid of the problem for me. While not a great solution, it works for me for now.
Comment 16 Arto Oksanen 2009-03-04 07:28:01 EST
I have the same problem here! I am running F10 (i686) on 64-bit AMD cpu. Disabling the screen saver helped somewhat, but did not remove the problem completly.
Comment 17 Christos P. Sotiriou 2009-03-04 08:27:35 EST
I have cloned a new bug report so that it's unrelated to ATI and related to kernel. Please use this one:

https://bugzilla.redhat.com/show_bug.cgi?id=488395

I would recommend that you try "noapic acpi=off" in your kernel command line (grub) and see whether the freezes go away.
Comment 18 JC 2009-05-16 12:07:51 EDT
Same issue here: random freezing while idle.

In some instances of the freezes, I am able to log in via SSH and kill X. And then everything is good for some time, but then it occurs again.

One of the times it happened, I noticed that metacity (GNOME's window manager) was using 99% of the CPU so I rebooted and switched to KDE.  However, the problem still happens with KDE, although now it just freezes completely and I cant even ssh into it.

Maintainers: could you please advise as to what sort of information or troubleshooting you need, from those affected by this issue, to help you in solving this problem?

I am willing to write utilities or whatever you need.  Just let me know what I am supposed to be looking at because I have no clue as to where to begin. /var/log/messages does not show anything valuable at the time of the crash...

Thanks!
Comment 19 Jérôme Glisse 2009-10-15 10:59:09 EDT
Do you still have this issue with fedora 12 (you can test livecd from http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/) ?
Comment 20 JC 2009-10-15 15:45:08 EDT
Hi, I apologize for not updating the status here.  I switched to FEDORA 11 and the issue is no longer there.
Comment 21 Jérôme Glisse 2009-10-16 07:29:29 EDT
Ok so closing the bug.

Note You need to log in before you can comment on or make changes to this bug.