Bug 47496 - Kickstart'd installation doesn't create initrd image even though needed
Kickstart'd installation doesn't create initrd image even though needed
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-05 15:02 EDT by Need Real Name
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-10 13:28:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-05 15:02:31 EDT
Description of Problem:

My kickstart installation fails to create an initrd image despite I have a Compaq array controller (scsi device).
Lilo seems to be installed, but without any reference to initrd whatsoever. And once the image is missing,
the kernel cannot mount root filesystem.

I have tried adding

device scsi cpqarray 

into kickstart file, but it didn't help. The installation otherwise works all right and finishes without any errors.
I have all the newest versions of RPMs. This very same configuration worked in 6.2, so it seems like a bug.
Comment 1 Need Real Name 2001-07-10 07:00:11 EDT
Could it be that because the kernel on installation initrd is different version (2.4.2) than
the one that is on the RPMs to be installed (2.4.3) it cannot make the initrd as
the needed modules are not found?
Comment 2 Brent Fox 2001-07-10 12:22:33 EDT
I have not seen this problem before.  Kickstart installs on ProLiants with the
Compaq Smart Array controller have created initrd's for me with 7.1.  What kind
of install are you doing?  (CDROM, NFS, etc.)?
Comment 3 Need Real Name 2001-07-10 13:28:13 EDT
It's a cd-rom installation off a custom made single installation cd of updated
RPMs. The cd is my current suspect, I am trying to find out if the culprit could
be one of the updated RPMs.
Comment 4 Need Real Name 2001-07-10 16:21:18 EDT
After comparing RPM list for a second time, I noticed that losetup package had been missing.
Very sorry to bother you with this.

Note You need to log in before you can comment on or make changes to this bug.