Bug 474960 - lirc upgrade postinstall doesn't restart daemon
lirc upgrade postinstall doesn't restart daemon
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lirc (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 21:42 EST by Bruce Jerrick
Modified: 2009-03-18 15:14 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.8.4a-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-18 15:01:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Jerrick 2008-12-05 21:42:21 EST
Description of problem:
When updating lirc, the daemon is not restarted.

Version-Release number of selected component (if applicable):
lirc-0.8.4a-1.fc9

How reproducible:
Always.

Steps to Reproduce:
1. Install an upgrade to lirc.
2. Examine results of 'service lirc status'.
  
Actual results:
Daemon is not running.

Expected results:
Daemon should be running.

Additional info:
Examination of 'rpm -q --scripts lirc' shows the reason:
There should be a '/etc/rc.d/init.d/lirc restart' (or just 'start') in
the postinstall scriptlet.
Instead, there's a '... try-restart' in the postuninstall scriptlet (why?).
Comment 1 Jarod Wilson 2009-03-17 11:30:41 EDT
Fixed in rawhide. I suppose I could fix F9 and F10 too...
Comment 2 Jarod Wilson 2009-03-17 11:42:00 EDT
F9 and F10 versions w/the fix building now.
Comment 3 Fedora Update System 2009-03-17 11:56:40 EDT
lirc-0.8.4a-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/lirc-0.8.4a-2.fc10
Comment 4 Fedora Update System 2009-03-17 11:57:29 EDT
lirc-0.8.4a-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/lirc-0.8.4a-2.fc9
Comment 5 Fedora Update System 2009-03-18 15:01:18 EDT
lirc-0.8.4a-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-03-18 15:14:35 EDT
lirc-0.8.4a-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.