Bug 474966 - Password Dialog Box is Stupid as Hell
Password Dialog Box is Stupid as Hell
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 23:06 EST by Johnny Proton
Modified: 2009-11-10 19:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 19:46:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Proton 2008-12-05 23:06:22 EST
I have tried to connect to my access point using F10 and it just doesn't work.  It authenticated on the LiveCD but for some ridiculous reason it doesn't work once I installed the system.

!! I actually contemplated moving to Ubuntu and had used their 8.10 
!! version for a few weeks but wanted to go back to Fedora (so I could 
!! use VMWare) and now I feel like a complete idiot for switching back.
!! That wont last long at all.

I use a Linksys 610N and WPA2 Personal for authentication, and my laptop is a Sony Vaio Z series, using an Intel 80211.abgn adapter.

Since my NetworkManager doesn't ever fucking connect to the access point, I am constantly presented by a dialog box asking me to retype my passphrase, however, when I click "show password" it doesn't show the passphrase I entered, it shows a bunch of shit that doesn't match at all.  So I need to keep typing it back in again, and again, and again.  It never connects to the access point.

It's like since I use a passphrase, it is translating it to hex or something, and the hex version of my passphrase is what it shows me on the dialog box.

DID I MENTION THAT THIS WORKED FINE ON UBUNTU???  Ubuntu did have the issue where the passphrase was displayed as hex, but it could at least connect to my wireless and allow me to keep working.

THIS IS A USABILITY NIGHTMARE!!!

You guys need to get a few focus groups going.  No one without a PhD in NerdDom is going to ever be able to figure out how to use Linux if guys like you keep pushing all this garbage down our throats.
Comment 1 Dan Williams 2008-12-09 12:18:31 EST
For the record, the password dialog box is essentially the same as on Mac OS X, so if we get it wrong, they get it wrong too.

I assume that you have an Intel 4965 or Intel 5300/5100?  If so, which exact one?  Are you hiding your access point's SSID?
Comment 2 Jessica Sterling 2009-03-06 17:49:11 EST
This bug has been triaged.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Dan Williams 2009-11-10 19:46:11 EST
BTW, current Fedora 11 and Fedora 10 updates in updates-testing will show you your original passphrase (not the hashed hex key).

If the problem of never connecting to the AP shows up again with latest F10 or F11 or F12 updates, please file a new bug for that as it's a different problem and likely related to buggy drivers.  Thanks!

F11: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10696  
F10: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-10546

Note You need to log in before you can comment on or make changes to this bug.