Bug 474977 - Severe showstopping regressions with Radeon 9600XT in F10
Severe showstopping regressions with Radeon 9600XT in F10
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 05:08 EST by Callum Lerwick
Modified: 2009-02-28 12:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-15 16:59:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf (2.50 KB, text/plain)
2008-12-06 05:13 EST, Callum Lerwick
no flags Details
Xorg log (175.03 KB, text/plain)
2008-12-06 05:16 EST, Callum Lerwick
no flags Details
Screenshot of glxgears with "nomodeset" (12.34 KB, image/png)
2009-01-18 19:33 EST, Callum Lerwick
no flags Details

  None (edit)
Description Callum Lerwick 2008-12-06 05:08:56 EST
Description of problem:

While glxgears seems to work, less trivial OpenGL apps will lock up the system hard. At one point "glchess" from gnome-games was triggering it, though the very latest drivers seem to no longer hang. Yellow rose still hangs it, available here:

http://ftp.kameli.net/pub/fit/yellow_rose/yellow_rose.c-src.tar.gz

I'm hesitant to do much more experimentation as hard system lockups are very unhealthy for my filesystems and this is my critical primary desktop machine...

Also any use of the video overlay seems to lock up the X server. The mouse cursor still moves but otherwise does not respond to anything else. If I ssh in, plain kill doesn't work, I have to kill -9 it. In which case the server apparently restarts, but the display is all corrupted and it doesn't seem to respond to ctl-alt-backspace or console switching, killing off the server does not restore the text console, the console seems to be completely screwed up and the only option is to reboot. Totem, swfdec, xine and mythtv frontend all trigger it.

OpenGL and video playback worked perfectly in F9. This is a rather severe regression IMO, as just opening an OpenGL app results in an instantly dead system, and any inadvertent video playback results in a locked up X server and a completely screwed console.

Workaround: Revert to xorg-x11-drv-ati from F9. OpenGL reverts to software rendering which at least doesn't lock the system up, and video playback works.

Smolt link:

http://smolt.fedoraproject.org/show?uuid=pub_622c8ebe-d72d-4a4a-9f49-818351c2ec8a

Version-Release number of selected component (if applicable):

xorg-x11-drv-ati-6.9.0-59.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run OpenGL apps
2. Play videos with totem
  
Actual results:
Death.

Expected results:
Life.
Comment 1 Callum Lerwick 2008-12-06 05:13:34 EST
Created attachment 325976 [details]
xorg.conf
Comment 2 Callum Lerwick 2008-12-06 05:16:05 EST
Created attachment 325977 [details]
Xorg log
Comment 3 Callum Lerwick 2009-01-18 19:31:26 EST
Hmmm, so I tried it with "nomodeset". OpenGL still doesn't work right, it seems to render to one row of tiles along the top of the screen, and it crashes a lot. Attempting to move the glxgears window results in:

glxgears: r300_state.c:1165: r300UpdateDrawBuffer: Assertion `rrb->pitch' failed.
Aborted

But at least it doesn't seem to hang the machine. And video overlay works.

Attaching a cropped screenshot of glxgears.
Comment 4 Callum Lerwick 2009-01-18 19:33:21 EST
Created attachment 329312 [details]
Screenshot of glxgears with "nomodeset"
Comment 5 Callum Lerwick 2009-01-18 19:38:34 EST
BTW that is with:

xorg-x11-drv-ati-6.9.0-63.fc10.x86_64
kernel-2.6.27.9-159.fc10.x86_64
Comment 7 Callum Lerwick 2009-02-15 16:59:49 EST
Okay so I've upgraded to:

xorg-x11-drv-ati-6.10.0-2.fc10.x86_64
kernel-2.6.27.12-170.2.5.fc10.x86_64

Which have made it in to the released updates repo. Things are still broken with "nomodeset", but things seem to sort of work with modesetting now. Video overlay works. I'm able to play a game of Quake 3 with no problem, but performance seems to suck, which is a known problem I guess. Gamma setting with modesetting seems to not work, so Quake 3 is really really dark and moving the slider makes no difference. Second Life crashes during login, and trying to run WoW under Wine crashes the X server. But I suppose those are bugs for another bug report...

I'm going to consider this fixed.
Comment 8 Callum Lerwick 2009-02-28 12:57:43 EST
May have spoke too soon. See bz487432

Note You need to log in before you can comment on or make changes to this bug.