Bug 474996 - extremely slow start with cluster.conf
extremely slow start with cluster.conf
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-lvm (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Marek Grac
Fedora Extras Quality Assurance
:
Depends On: 516879
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 09:22 EST by ritz
Modified: 2009-08-26 22:13 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.1.9-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-26 22:13:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
profile information (44.85 KB, text/plain)
2008-12-06 09:22 EST, ritz
no flags Details
Proposed patch (1.55 KB, patch)
2009-08-12 12:58 EDT, Marek Grac
no flags Details | Diff

  None (edit)
Description ritz 2008-12-06 09:22:15 EST
Created attachment 325999 [details]
profile information

Description of problem:
system-config-lvm extremely slow

Version-Release number of selected component (if applicable):
system-config-lvm-1.1.4-3.1.fc10.noarch

How reproducible:
always

Steps to Reproduce:
1. run system-config-lvm, takes about 20mins to start up
  
Actual results:
slooooow start-up

Expected results:
fast start-up

Additional info:
s-c-l profile. seems to be an issue with cluster.py, we need most likely need to use cache 

    def __get_info(self):
        try:
            c_conf = minidom.parseString(file('/etc/cluster/cluster.conf').read(10000000)).firstChild
<----- bad mojo
            name = c_conf.getAttribute('name')
            lock = 'dlm'
            nodes_num = 0
            for node in c_conf.childNodes:
                if node.nodeType == xml.dom.Node.ELEMENT_NODE:
                    if node.nodeName == 'cman':
                        lock = 'dlm'
                    elif node.nodeName == 'gulm':
                        lock = 'gulm'
                    elif node.nodeName == 'clusternodes':
                        nodes = node
                        for node in nodes.childNodes:
                            if node.nodeType == xml.dom.Node.ELEMENT_NODE:
                                if node.nodeName == 'clusternode':
                                    nodes_num += 1
            if nodes_num != 0:
Comment 1 Marek Grac 2009-08-12 12:58:37 EDT
Created attachment 357205 [details]
Proposed patch

Patch that adds caching to cluster.conf parsing
Comment 2 Fedora Update System 2009-08-20 09:03:59 EDT
system-config-lvm-1.1.8-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/system-config-lvm-1.1.8-1.fc10
Comment 3 Fedora Update System 2009-08-20 19:00:59 EDT
system-config-lvm-1.1.9-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/system-config-lvm-1.1.9-1.fc10
Comment 4 Fedora Update System 2009-08-21 21:02:15 EDT
system-config-lvm-1.1.9-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-lvm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8861
Comment 5 Fedora Update System 2009-08-26 22:13:03 EDT
system-config-lvm-1.1.9-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.