Bug 475022 - Firefox crashes consistently on specific text-only web pages
Firefox crashes consistently on specific text-only web pages
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 14:45 EST by Carl Roth
Modified: 2009-04-06 04:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-06 04:28:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb session trace (58.97 KB, text/plain)
2008-12-06 14:46 EST, Carl Roth
no flags Details

  None (edit)
Description Carl Roth 2008-12-06 14:45:40 EST
Description of problem:

When I try to view

  http://docs.python.org/library/zipfile.html

with firefox it crashes as I scroll down the page.  It says

QPixmap: Invalid pixmap parameters
The program 'firefox' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 52510 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Locking assertion failure.  Backtrace:
#0 /usr/lib64/libxcb-xlib.so.0 [0x34f3a0097c]
#1 /usr/lib64/libxcb-xlib.so.0(xcb_xlib_lock+0x17) [0x34f3a00af7]
#2 /usr/lib64/libX11.so.6 [0x34f3e4c610]
#3 /usr/lib64/libXrender.so.1(XRenderFreePicture+0x46) [0x34f6204826]
#4 /usr/lib64/libQtGui.so.4 [0x31a96468eb]
#5 /usr/lib64/libQtGui.so.4 [0x31a9647270]
#6 /usr/lib64/libQtGui.so.4(_ZN7QPixmap5derefEv+0x53) [0x31a963cb93]
#7 /usr/lib64/libQtGui.so.4(_ZN7QPixmapD1Ev+0x24) [0x31a963ced4]
#8 /usr/lib64/libQtGui.so.4 [0x31a971ef9b]
#9 /usr/lib64/libQtGui.so.4 [0x31a9717719]
#10 /usr/lib64/libQtGui.so.4 [0x31a9646848]
#11 /usr/lib64/libQtGui.so.4 [0x31a9647270]
#12 /usr/lib64/libQtGui.so.4(_ZN7QPixmap5derefEv+0x53) [0x31a963cb93]
#13 /usr/lib64/libQtGui.so.4(_ZN7QPixmapD2Ev+0x24) [0x31a963cf24]
#14 /usr/lib64/libQtGui.so.4 [0x31a9641d83]
#15 /usr/lib64/libQtGui.so.4 [0x31a964238f]
#16 /usr/lib64/libQtGui.so.4 [0x31a9641a75]
#17 /lib64/libc.so.6(exit+0x9d) [0x36568358ad]
#18 /usr/lib64/libgdk-x11-2.0.so.0 [0x3bf9a64767]
#19 /usr/lib64/libX11.so.6(_XError+0xf4) [0x34f3e45524]

I'm attaching a more detailed output from 'firefox -g -sync ...' and gdb.  Note from the gdb session trace that thread #8 cannot be queried (it generates a gdb internal error).  Oops!

Version-Release number of selected component (if applicable):

libX11-1.1.4-1.fc9.x86_64
qt-x11-4.4.3-5.fc9.x86_64
gtk2-2.12.12-1.fc9.x86_64
libXrender-0.9.4-3.fc9.i386
libxcb-1.1-5.fc9.x86_64
glibc-2.8-8.x86_64
xorg-x11-drv-ati-6.8.0-19.fc9.x86_64

(note that the firefox debug trace indicates references to the fglrx driver, but it is not installed on this system.)

How reproducible:

Always

Steps to Reproduce:
1. start firefox
2. go to http://docs.python.org/library/zipfile.html
3. scroll down with the arrow keys
  
Actual results:


Expected results:


Additional info:

This is using a KDE desktop (should be obvious from the firefox traceback).
Comment 1 Carl Roth 2008-12-06 14:46:36 EST
Created attachment 326015 [details]
gdb session trace
Comment 2 Matěj Cepl 2008-12-06 17:14:46 EST
a) cannot reproduce here,
b) there is no way how could firefox crash in Qt library, because it has absolutely nothing with it.

Reassigning to Qt folks.
Comment 3 Kevin Kofler 2008-12-06 18:03:52 EST
There is a way... gtk-qt-engine.
Comment 4 Matěj Cepl 2008-12-07 05:10:28 EST
Sure, we may get back to bug being in Firefox, but I would first suspect either qt or gtk-qt-engine itself.
Comment 5 Rex Dieter 2009-03-26 10:16:41 EDT
Reporter, is this still reproducible?  Which kde style/theme are you using (default oxygen?)
Comment 6 Carl Roth 2009-04-06 04:28:16 EDT
Updated Fedora, firefox, kde, now the problem is not reproducable.  Yay?

Note You need to log in before you can comment on or make changes to this bug.