Bug 475028 - alsa-lib-devel multilib installation error
alsa-lib-devel multilib installation error
Status: CLOSED DUPLICATE of bug 465205
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 15:09 EST by Alexandre Oliva
Modified: 2009-02-04 07:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 07:27:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2008-12-06 15:09:05 EST
Description of problem:
If you select alsa-lib-devel.x86_64 and alsa-lib-devel.i386 in a kickstart file (say, because you want them installed so that gcc's libjava multilibs won't fail quite late in the build), you get an error about file conflicts.

The only way to install both multilibs of alsa-lib-devel (that *are* in the x86_64 install media) is to pass --replacefiles to rpm, post installation.  Installing everything doesn't work, because anaconda doesn't do that.  In fact, it only reports an error long after having formatted the root and boot filesystem, and you can't go back and adjust the package selections in a kickstart install.

Anyhow, it's pretty important to be able to install both packages without conflicts for development of gcc, so if you could please arrange for this conflict to be avoided (say, by moving the conflicting files to a separate packages that does not require multilibs), that would be great.

Version-Release number of selected component (if applicable):
alsa-lib-devel-1.0.18-6.rc3.fc10

How reproducible:
Every time

Actual results:
	file /usr/share/doc/alsa-lib-devel-1.0.18/doxygen/html/_2test_2latency_8c-example.html from install of alsa-lib-devel-1.0.18-6.rc3.fc10.x86_64 conflicts with file from package alsa-lib-devel-1.0.18-6.rc3.fc10.i386
	file /usr/share/doc/alsa-lib-devel-1.0.18/doxygen/html/_2test_2pcm_8c-example.html from install of alsa-lib-devel-1.0.18-6.rc3.fc10.x86_64 conflicts with file from package alsa-lib-devel-1.0.18-6.rc3.fc10.i386
	file /usr/share/doc/alsa-lib-devel-1.0.18/doxygen/html/_2test_2pcm__min_8c-example.html from install of alsa-lib-devel-1.0.18-6.rc3.fc10.x86_64 conflicts with file from package alsa-lib-devel-1.0.18-6.rc3.fc10.i386
[660 other similar messages, all in /doxygen/html/

Expected results:
No conflicts

Additional info:
Although the conflict has been around for a while (Fedora 8, if not longer), Fedora 9's anaconda used to hide these conflicts and install both packages anyway.  yum and rpm would still report conflicts and require rpm --replacefiles.  I know because I added these packages to my kickstart files to avoid post-install installation conflicts.
Comment 1 Jaroslav Kysela 2009-02-04 07:27:15 EST

*** This bug has been marked as a duplicate of bug 465205 ***

Note You need to log in before you can comment on or make changes to this bug.