Bug 475043 - Installing F-10 under OS X 10.5/Bootcamp clobbers EFI partition, breaks iMac
Installing F-10 under OS X 10.5/Bootcamp clobbers EFI partition, breaks iMac
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 18:43 EST by Michael DeHaan
Modified: 2009-02-05 15:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 15:09:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael DeHaan 2008-12-06 18:43:27 EST
Description of problem:

Tried installing F10 under a new OS X 10.5 bootcamp partition, size 25 GB.   Install works mostly fine (except grub did not recognize the keyboard) though when finished the boot loader always picked Fedora despite being installed into /dev/sda3.  

The partitioning layout I chose was to leave everything unaltered and just to format /dev/sda3 -- mounting as root with ext3fs

I contacted Apple support and we exhausted all EFI keyboard options to select a boot device and so forth and determined that grub (or something else) either damaged the EFI boot loader (I could not boot to any kind of install DVD, only Fedora on the hard drive)

Fedora actually worked fine other than the grub problem (I suspect the non-standard USB keyboard was to blame) but the clobbering of EFI required taking the computer to an Apple store to have it reprovisioned over the network -- to restore the EFI partition.  

Erasing the hard drive in Linux doesn't help, the EFI partition is on the hard drive, so if that's ruined, you have to netboot the system to get it working again.

If I had to summarize, I think the root problem is that even though I selected to install grub on /dev/sda3 I think the installer (or grub-install) ignored my choice and did /something/ to the EFI partition.

Version-Release number of selected component (if applicable):

Fedora 10 Gold DVD
OS X 10.5.11 with latest updates

How reproducible:

I'm not going to try, but I would assume very.


Steps to Reproduce:
1.   See description above
2.
3.
  
Actual results:

Fried EFI partition, can't use any of the EFI control code sequences (holding down option, or command-option-o-f, etc, get Fedora booting every single time)

Expected results:

Should preserve OS X boot loader and work as does a Windows dual boot install (which I swear to the penguins I haven't had in a long time, but I've seen it and I know how it works)

Additional info:

Can supply more info as needed but can't try it again on this box.
Comment 1 Jeremy Katz 2008-12-08 10:43:23 EST
I actually did a Fedora install the other day on an Intel Mac without any problems.

A few questions
1) Did you boot from the efi boot image or a regular CD/DVD?
2) How did you do the partitioning?
3) Where did you say to install the boot loader?

Booting from CD/DVD and following the defaults should Just Work (tm).  There might be combinations of manual options that are bad that we don't catch.
Comment 2 Michael DeHaan 2008-12-08 10:53:16 EST
1) The OS installer was booted from the regular CD/DVD, by inserting the CD and restarting during the BootCamp wizard.  Initially the BC wizard refused to restart because it could not find Windows on the ISO (of course), though restarting the imac launched the installer.

2) Manual partitioning.  I had three partitions (EFI, OS, and Windows/vfat) created by the bootcamp assistant.  I reformatted the vfat as ext3fs only and did not create a swap because I did not trust bootcamp enough do to the right thing if I subdivided the final space (though that /should/ work).

3) /dev/sda3, definitely not the first disk.  Checked this a few times because I knew that would do bad things if I chose incorrectly.

The install completed fine from there but seems to have (my guess) installed the bootloader onto /dev/sda instead given nearly all of the EFI commands (except hold down mouse, which might be implemented in the pre-EFI bits) were not functional.
Comment 3 Jeremy Katz 2008-12-08 11:03:52 EST
(In reply to comment #2)
> 1) The OS installer was booted from the regular CD/DVD, by inserting the CD and
> restarting during the BootCamp wizard.  Initially the BC wizard refused to
> restart because it could not find Windows on the ISO (of course), though
> restarting the imac launched the installer.

Hmmm... I actually haven't used the BootCamp wizard in a while.  I wonder if a newer version of it is doing something silly and unexpected

> 2) Manual partitioning.  I had three partitions (EFI, OS, and Windows/vfat)
> created by the bootcamp assistant.  I reformatted the vfat as ext3fs only and
> did not create a swap because I did not trust bootcamp enough do to the right
> thing if I subdivided the final space (though that /should/ work).

Yeah, subdividing the space should be fine.  I've actually either resized and left the free space or deleted and created a "normal" scheme where the vfat got placed by BootCamp.

> 3) /dev/sda3, definitely not the first disk.  Checked this a few times because
> I knew that would do bad things if I chose incorrectly.

That should be right.

> The install completed fine from there but seems to have (my guess) installed
> the bootloader onto /dev/sda instead given nearly all of the EFI commands
> (except hold down mouse, which might be implemented in the pre-EFI bits) were
> not functional.

When you rescued it, it blew away the Fedora install I'm guessing and so you can't get a log?  

But EFI is all firmware based, so even if everything got deleted, it shouldn't throw things off.  You had the latest firmware installed, right?  Which gen of iMac is this on and I'll see if I can find a similarly aged box to try on.
Comment 4 Michael DeHaan 2008-12-08 11:20:53 EST
(A) Possible.  This was OS X 10.5, most likely 10.5.11

(B) yep

(C) yep

(D) Correct, no log available, unfortunately.  If I had a Apple netboot server around I'd be more than happy to retry it, but I don't...

The funny thing about all of this is that while EFI is technically "firmware" it seems to rely a /lot/ on the contents of the EFI partition, and it seems that this was basically a damaged EFI partition so only "hold down N" (netboot) and "hold down mouse" (eject) works, while other option codes like "hold down option" (chose partition to boot from) do not work.

It's the first generation of Intel iMacs (Core 2 Duo, 2 Ghz, 2 GB RAM, before they went to the slightly thinner models).
Comment 5 Jeremy Katz 2008-12-08 11:49:13 EST
I'll dig up a box and go through the steps with the actual Boot Camp wizard and see if I can reproduce.  Sadly, I'm quite used to restoring from DVD now if needed.

FWIW, the steps that I followed last week that definitely worked:
a) Boot into an OS/X install DVD, open a terminal.  'diskutil resizeVolume /path/to/disk sizeToKeep'
b) Reboot into OS/X to make sure everything is ok
c) Boot into Fedora install CD by holding down 'C' while booting
d) Autopartition, accept defaults for bootloader, etc.  
e) Success!

(In reply to comment #4)
> The funny thing about all of this is that while EFI is technically "firmware"
> it seems to rely a /lot/ on the contents of the EFI partition, and it seems
> that this was basically a damaged EFI partition so only "hold down N" (netboot)
> and "hold down mouse" (eject) works, while other option codes like "hold down
> option" (chose partition to boot from) do not work.

That's really really odd and doesn't at all match anything I've seen on any of the Macbooks.  The only contents of the EFI partition should be the blessing bits which is how the EFI implementation on the Macs decides to boot from it.

My current hunch is that BootCamp doesn't set up a proper MBR anymore and so the chainload didn't work.  But that still doesn't explain why OS/X wouldn't boot... unless it was stuck in some loop where it needed to successfully boot from the legacy OS before going back to booting from EFI
Comment 6 Jeremy Katz 2009-02-05 15:09:23 EST
Okay, I just did exactly this steps on a first gen Mac Mini (with a fresh OS/X install even) and didn't have any problems.  It defaulted to booting into Fedora, holding down left alt when turning the box on brought up the EFI-based selecter.

The only thing I can think is that you did something a little different (used the EFI partition as /boot?) or something else just happened to gremlin on your machine at the same time :/

And I definitely haven't seen any other reports of it, but there are certainly a decent number of reports of other things from people running Fedora on a Mac

Note You need to log in before you can comment on or make changes to this bug.