Bug 475063 - UI issues in iok
UI issues in iok
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iok (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 01:06 EST by Matthias Clasen
Modified: 2009-09-21 17:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-08 22:53:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2008-12-07 01:06:44 EST
Some issues I noticed while I briefly looked at iok:

- First a general issue: I believe it would be much more useful if iok would appear less like a normal unfocused application window, and more like some special desktop component. Ie, I would remove the window title and menubar, and maybe place the window at some fixed place, e.g. above the bottom panel (compare matchbox-keyboard).

- It seems somewhat pointless to have an "Advanced Options" check menuitem with the sole purpose of hiding and showing another menu. Also, I wonder why you think that "Open" is less advanced than "Save".

- The buttons are pretty hard to hit on a big screen,since they don't reserve any extra size beyond the dimensions of the character. (compare gnome-calculator, which does ensure that its buttons have reasonable size)

- The entries in the combobox should be translatable language names, like "Assamese", not technobabble like "as-inscript". If you use the iso-codes package for this, you get translations of the language names for free.

- The "Open" menuitem doesn't give any guidance as to what kind of file you are expected to open. I'd recommend to make that "Open keymap", add a filter to the filechooser that only shows .mim files, and opening the file chooser in the /usr/share/m17n directory.

- "Save keymap" would be better if it opened a file chooser in save mode, and proposed a filename like 'modified-as-inscript.mim'.
Comment 1 Parag Nemade 2008-12-08 03:27:28 EST
(In reply to comment #0)
> Some issues I noticed while I briefly looked at iok:
> 
Thanks for having brief look.

> - First a general issue: I believe it would be much more useful if iok would
> appear less like a normal unfocused application window, and more like some
> special desktop component. Ie, I would remove the window title and menubar, and
> maybe place the window at some fixed place, e.g. above the bottom panel
> (compare matchbox-keyboard).

  I will think about that as I saw its difflicult to close matchbox-keyboard once its started. Even then how can I provide features to save keymap,open keymap if I removed menubar?


> 
> - It seems somewhat pointless to have an "Advanced Options" check menuitem with
> the sole purpose of hiding and showing another menu. Also, I wonder why you
> think that "Open" is less advanced than "Save".
 
  Sorry I confused here what you want to suggest.

> 
> - The buttons are pretty hard to hit on a big screen,since they don't reserve
> any extra size beyond the dimensions of the character. (compare
> gnome-calculator, which does ensure that its buttons have reasonable size)

  The reason I removed specific size to button is that UI varies from language to language. Like telugu, Kannada characters are big in size so UI's size(height as well as in lenght) will vary as you change from Hindi inscript to Telugu inscript map.
  Will check gcalctool source to fix above issue.

> 
> - The entries in the combobox should be translatable language names, like
> "Assamese", not technobabble like "as-inscript". If you use the iso-codes
> package for this, you get translations of the language names for free.
 
  Ok. So for standard installed inscript maps I will use Language names. How do you like to see then modfied keymaps for same language in combo box?


> - The "Open" menuitem doesn't give any guidance as to what kind of file you are
> expected to open. I'd recommend to make that "Open keymap", add a filter to the
> filechooser that only shows .mim files, and opening the file chooser in the
> /usr/share/m17n directory.

  Done.
> 
> - "Save keymap" would be better if it opened a file chooser in save mode, and
> proposed a filename like 'modified-as-inscript.mim'.
      
   What do you suggest if end user want to change as-inscript say 2 times and want to have those 2 copies? I actually confused where should modified keymaps go. Currently, as non-root user can't write to /usr/share/m17n, I am storing new/modified keymaps in $HOME/.m17n which is not good location as its hidden directory but iok is made to list keymaps in $HOME/.m17n directory.
Comment 2 Matthias Clasen 2008-12-08 10:59:17 EST
> 
> > - First a general issue: I believe it would be much more useful if iok would
> > appear less like a normal unfocused application window, and more like some
> > special desktop component. Ie, I would remove the window title and menubar, and
> > maybe place the window at some fixed place, e.g. above the bottom panel
> > (compare matchbox-keyboard).
> 
>   I will think about that as I saw its difflicult to close matchbox-keyboard
> once its started. Even then how can I provide features to save keymap,open
> keymap if I removed menubar?

I was thinking that you could add a button that brings up a configuration dialog. 

> > 
> > - It seems somewhat pointless to have an "Advanced Options" check menuitem with
> > the sole purpose of hiding and showing another menu. Also, I wonder why you
> > think that "Open" is less advanced than "Save".
> 
>   Sorry I confused here what you want to suggest.

I wasn't clear. I think there is no point in having the "Advanced Options" menuitem if its sole purpose is to hide the other menu. Either just show the "Keys" menu always, or, if you want to make it more obvious that this is 'advanced' stuff, turn the "Advanced Options" menuitem into a submenu with those options.


>   The reason I removed specific size to button is that UI varies from language
> to language. Like telugu, Kannada characters are big in size so UI's
> size(height as well as in lenght) will vary as you change from Hindi inscript
> to Telugu inscript map.
>   Will check gcalctool source to fix above issue.

They don't have to be all the same size, but having a reasonable minimal size would be nice, since they are just too small to hit.
 
> > - The entries in the combobox should be translatable language names, like
> > "Assamese", not technobabble like "as-inscript". If you use the iso-codes
> > package for this, you get translations of the language names for free.
> 
>   Ok. So for standard installed inscript maps I will use Language names. How do
> you like to see then modfied keymaps for same language in combo box?

I mostly care about the standard ones that will be there by default. For 
modified keymaps, you can either just show the basename of the file, or 
enhance the saving ui to ask for a name in addition to a filename.

> > 
> > - "Save keymap" would be better if it opened a file chooser in save mode, and
> > proposed a filename like 'modified-as-inscript.mim'.
> 
>    What do you suggest if end user want to change as-inscript say 2 times and
> want to have those 2 copies? I actually confused where should modified keymaps
> go. Currently, as non-root user can't write to /usr/share/m17n, I am storing
> new/modified keymaps in $HOME/.m17n which is not good location as its hidden
> directory but iok is made to list keymaps in $HOME/.m17n directory.

Obviously, modified keymaps have to be stored in the users home directory somewhere. ~/.m17n seems a fine location for that. I don't think it is a problem that it is hidden. The important thing is that the files show up in the tool that they are made for, and you seem to have that covered.
Comment 3 Parag Nemade 2008-12-15 23:24:54 EST
Just to update I am working on fixing issues reported in this bug
Comment 4 Parag Nemade 2009-01-21 23:01:58 EST
With iok-1.2.0 release, button sizes are now good to be hit using mouse. About making iok remove window titlebar and menubar, I will think on it later on as we also need keymap customizing features in same iok window interface.
Comment 5 Parag Nemade 2009-02-08 22:53:36 EST
Closing this for now. KLindly open new bug if still some problem is seen in iok-1.2.0 release.

Note You need to log in before you can comment on or make changes to this bug.