Bug 475075 - I fixed Bidirational problems in xsl for gnome-doc-utils
I fixed Bidirational problems in xsl for gnome-doc-utils
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-doc-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 08:48 EST by Muayyad Alsadi
Modified: 2009-01-05 10:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 10:50:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch -p1 (2.13 KB, application/x-gzip)
2008-12-07 08:48 EST, Muayyad Alsadi
no flags Details
Corrected patch (11.62 KB, patch)
2009-01-05 10:46 EST, Matthew Barnes
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 563559 None None None Never

  None (edit)
Description Muayyad Alsadi 2008-12-07 08:48:06 EST
Created attachment 326039 [details]
patch -p1

Please describe the problem:
All Arrows, boxes ...etc. should be mirrored for right to left languages

Steps to reproduce:
1. open yelp for an English document then Arabic document
2. notice the layout



Actual results:
for Arabic things are aligned to left instead of right 

Expected results:
right to left layout

Does this happen every time?
yes


Additional info:
the fix does not affect other languages
Comment 1 Matthew Barnes 2009-01-05 10:46:12 EST
Created attachment 328207 [details]
Corrected patch

Patch was gzipped twice and misnamed.  Here's the actual patch.
Comment 2 Matthew Barnes 2009-01-05 10:50:03 EST
Looks like the patch has had extensive review in the GNOME bug, so I'll defer to Shaun's judgement and wait for the work to be committed upstream.

Note You need to log in before you can comment on or make changes to this bug.