Bug 475081 - Komercni banka's online banking does not work
Komercni banka's online banking does not work
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 10:08 EST by Michal Nowak
Modified: 2013-03-07 21:05 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-02 10:41:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Log from Certification Guide & Komercni banka's/Moje banka's app (21.27 KB, text/plain)
2008-12-07 10:08 EST, Michal Nowak
no flags Details
Almost passe cert guide (66.58 KB, image/png)
2009-01-21 16:52 EST, Michal Nowak
no flags Details

  None (edit)
Description Michal Nowak 2008-12-07 10:08:07 EST
Created attachment 326044 [details]
Log from Certification Guide & Komercni banka's/Moje banka's app

Go to

    https://www.mojebanka.cz/InternetBanking/?L=CS
or  https://www.mojebanka.cz/InternetBanking/?L=EN

Output from Firefox:

[zuzana@assam ~]$ firefox --safe-mode
ICEDTEAPLUGIN_DEBUG = (null)
ICEDTEAPLUGIN_DEBUG = (null)
Initializing JVM...
NOT IMPLEMENTED: virtual nsresult IcedTeaPluginInstance::Start()
NOT IMPLEMENTED: virtual nsresult IcedTeaPluginInstance::Start()
Jar string: /jars/detectVM.jar
jars length: 1
JNLPRuntime already initialized
JNLPRuntime already initialized
netx: Initialization Error: Could not initialize applet. (java.lang.NullPointerException null)
netx: Initialization Error: Could not initialize applet. (java.lang.NullPointerException null)
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize applet.
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:472)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:418)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:597)
Caused by: java.lang.NullPointerException
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:458)
	... 2 more
Caused by: 
java.lang.NullPointerException
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:458)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:418)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:597)
IcedTeaPlugin.cc:3850: Error: Failed to flush bytes to output channel: Broken pipe



Web page still says:

"""
Downloading and initialization of the signing applet is in progress.
On computers with slow Internet connection,
this may take a while; wait please...
"""

But nothing downloads at all.



Go to 'Configuration Guide':

    https://www.mojebanka.cz/confwiz/install/ctrl-cw_lite/jsok.page?lang=cz

Four Java windows regarding digital security pops up, asking for trusting those Komercni banka's applets.

-> "Always trust..." -> Run

see kb.log

Some window from Firefox poped up, letting me know it might take some time to run thru the check -> OK.

Operační systém	Nalezený operační systém: Linux	OK
Internetový prohlížeč	Nalezený prohlížeč: Mozilla Firefox 3.0.4	OK
Cookies	Cookies jsou povoleny	OK
Nastavení času	Čas počítače a čas serveru jsou ve shodě. Čas počítače: Sun 07 Dec 2008 03:45:55 PM CET	OK
Podpora PDF formátu	Nalezena nepodporovaná verze prohlížeče PDF souborů.	NOOK
Dodavatel prostředí Java v prohlížeči	[dodavatel,metoda,version]:[Sun Microsystems Inc.,applet,1.6.0_0]	OK
Java v prohlížeči	Java je povolena v prohlížeči	OK
	
Ověření konfigurace aplikace
Instalace knihoven aplikace pro prostředí SUN	Nenainstalováno	BUSY
(mnowak: "Instalation of libraries for SUN environment -- NOTINSTALLED (busy '?' icon)".
Postinstalační test pro prostředí SUN JVM	N/A	NOINFO
(mnowak: postinstalation test of SUN JVM -- N/A)
Ověření přítomnosti ovladače čtečky čipových karet	N/A	NOINFO



The "Instalation of libraries for SUN environment" never ends

1) The Certifation Guide failes to fing working Java, see the log.
2) The page https://www.mojebanka.cz/InternetBanking/?L=CS won't let me to load the certification app & log me in.

java-1.6.0-openjdk-1.6.0.0-7.b12.fc10.i386
java-1.6.0-openjdk-plugin-1.6.0.0-7.b12.fc10.i386



I do remember it worked, at least I saw the log in app, this summer, looks like a regression.

I made it work with SUN's 1.6.0 Java on Ubuntu 8.04.1.
Comment 1 Deepak Bhole 2009-01-21 16:11:31 EST
Does the "Instalation of libraries for SUN environment" end with the Sun plugin? I tried 1.5 and 1.6 and it hangs for me with that too..

As for the main page (https://www.mojebanka.cz/InternetBanking/?L=EN) , it loads for me now with the latest upstream (which will be in Fedora soon with the next OpenJDK update).
Comment 2 Michal Nowak 2009-01-21 16:43:28 EST
(In reply to comment #1)
> Does the "Instalation of libraries for SUN environment" end with the Sun
> plugin? I tried 1.5 and 1.6 and it hangs for me with that too..

I bet it does, my significant other made it with SUN Java-1.6.0 on Ubuntu. 

W.r.t. Fedora's OpenJDK it says: 'Sun Microsystems Inc.,applet,1.6.0_0'. And, sure, I don't have the SUN's Java so it's our OpenJDK.

> As for the main page (https://www.mojebanka.cz/InternetBanking/?L=EN) , it
> loads for me now with the latest upstream (which will be in Fedora soon with
> the next OpenJDK update).

Still not for me with current F10, I eventually test it with Rawhide, when is the update in place.

Anyway, thanks for having a look on this.
Comment 3 Michal Nowak 2009-01-21 16:52:17 EST
Created attachment 329664 [details]
Almost passe cert guide

I believe the missing Adobe Reader won't a problem in real, I guess it's just for printouts. Although the cert guide look like (almost) averything is OK, it won't show me the applet for cert & password checking.
Comment 4 Lillian Angel 2009-02-02 10:41:54 EST
this should be in rawhide within the next couple of days:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1098935
Comment 5 Fedora Update System 2009-02-04 21:23:34 EST
java-1.6.0-openjdk-1.6.0.0-9.b14.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Michal Nowak 2009-02-05 03:17:36 EST
I confirm it's fixed now in Rawhide. Thanks.

Note You need to log in before you can comment on or make changes to this bug.