Bug 475082 - Review Request: guiloader - GuiXml Loader Library
Review Request: guiloader - GuiXml Loader Library
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 475107
  Show dependency treegraph
 
Reported: 2008-12-07 10:54 EST by Fabian Affolter
Modified: 2009-01-07 04:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 09:16:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mtasaka: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Fabian Affolter 2008-12-07 10:54:59 EST
Spec URL: http://fab.fedorapeople.org/packages/SRPMS/guiloader.spec
SRPM URL: http://fab.fedorapeople.org/packages/SRPMS/guiloader-2.12.0-1.fc9.src.rpm

Project URL: http://crow-designer.sourceforge.net/

Description:
GuiLoader is a high-performance and compact GuiXml loader
library. This library allows GTK+ applications to create GUI widgets
and objects at run-time from GuiXml resource files. GuiLoader is
written in C language as a GObject subclass and has a trivial
language-independent API. GuiLoader was designed to be easily wrapped
for any language that has GTK+ bindings.

Koji scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=985300 

rpmlint output:
[fab@laptop024 i386]$ rpmlint guiloader*
3 packages and 0 specfiles checked; 0 errors, 0 warnings.

[fab@laptop024 SRPMS]$ rpmlint guiloader*
1 packages and 0 specfiles checked; 0 errors, 0 warnings.

This Review Request based on an old Review Request. -> https://bugzilla.redhat.com/show_bug.cgi?id=206122

As in https://bugzilla.redhat.com/show_bug.cgi?id=206134 suggested from the original owner of the Review Request of guiloader, this is the new Review Request to bring this into Fedora.
Comment 1 Mamoru TASAKA 2008-12-07 13:10:25 EST
The latest seems 2.13.0.
Comment 2 Fabian Affolter 2008-12-07 15:08:12 EST
I know, but 2.13.0 needs newer libraries than are available for Fedora 9.

Requested 'glib-2.0 >= 2.18' but version of GLib is 2.16.6
Requested 'gtk+-2.0 >= 2.14' but version of GTK+ is 2.12.12

Per example, glib2 in Fedora 10 is 2.19.2.
Comment 3 Mamoru TASAKA 2008-12-08 12:27:15 EST
(In reply to comment #2)
> I know, but 2.13.0 needs newer libraries than are available for Fedora 9.
Ah, okay (but I recommand that for F-10+ you upgrade guiloader to 2.13.0)

By the way:
* Redundant (Build)Requires
  - Although configure.ac or .pc.in explicitly mention,
    glib2-devel is Required by gtk2-devel and
    "(Build)Requires: glib2-devel" is redundant.

I don't see other issues on this package.
---------------------------------------------------------------------
       This package (guiloader) is APPROVED by mtasaka
---------------------------------------------------------------------
Comment 4 Fabian Affolter 2008-12-10 14:20:55 EST
Mamoru, thank you for your review and the hint about the redundant BR.  I missed that point. 

I will update the source for F10 and devel.
Comment 5 Fedora Update System 2008-12-10 16:32:22 EST
guiloader-2.12.0-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/guiloader-2.12.0-2.fc9
Comment 6 Fedora Update System 2008-12-13 09:55:11 EST
guiloader-2.12.0-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update guiloader'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11197
Comment 7 Mamoru TASAKA 2008-12-15 00:47:19 EST
Please also submit updates request for F-10.
Comment 8 Fedora Update System 2008-12-15 03:49:39 EST
guiloader-2.13.0-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/guiloader-2.13.0-1.fc10
Comment 9 Mamoru TASAKA 2008-12-15 09:16:12 EST
Okay, thanks.
Comment 10 Fabian Affolter 2008-12-15 16:58:07 EST
Package Change Request
======================
Package Name: guiloader
Owners: fab
Updated Description: GuiXml Loader Library
Comment 11 Mamoru TASAKA 2008-12-16 10:31:28 EST
Resetting CVS request as there is already guiloader module
on Fedora CVS.
Comment 12 Fabian Affolter 2008-12-16 14:24:51 EST
It was a change request for the change of the name. Not a CVS Package request.
Comment 13 Fabian Affolter 2008-12-16 14:25:46 EST
Not the name, the Description.
Comment 14 Mamoru TASAKA 2008-12-17 01:42:45 EST
Ah, thanks
Comment 15 Kevin Fenzi 2008-12-17 19:30:34 EST
cvs done.
Comment 16 Fedora Update System 2009-01-07 04:11:32 EST
guiloader-2.13.0-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2009-01-07 04:22:18 EST
guiloader-2.12.0-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.