Bug 475090 - screen width beyond 2048 hangs system
screen width beyond 2048 hangs system
Status: CLOSED DUPLICATE of bug 474327
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 12:04 EST by Werner Gold
Modified: 2009-01-09 18:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 18:43:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf with virt width >2048 (1.59 KB, text/plain)
2008-12-07 15:51 EST, Werner Gold
no flags Details
First Xorg.log (48.99 KB, text/plain)
2008-12-07 15:55 EST, Werner Gold
no flags Details
Xorg.log from "X" command (16.96 KB, text/plain)
2008-12-07 15:58 EST, Werner Gold
no flags Details

  None (edit)
Description Werner Gold 2008-12-07 12:04:50 EST
Description of problem:

Setting a virtual screen of more than 2048 hangs the system.
Tried also without "rhgb" boot parameter in order to use intel driver instead of fb.

Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-2.5.0-3.fc10.i386

How reproducible:

Every Time

Steps to Reproduce:
1. Create xorg.conf and set Virtual larger than 2048

Actual results:

Graphics output corrupted, console unusable.
Comment 1 Matěj Cepl 2008-12-07 14:35:40 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Werner Gold 2008-12-07 15:51:17 EST
Created attachment 326053 [details]
xorg.conf with virt width >2048
Comment 3 Werner Gold 2008-12-07 15:55:07 EST
Created attachment 326054 [details]
First Xorg.log

Both logs look different. This one has been created:
No "rhgb" switch: Runlevel 3: "startx" command by root.
Complete system hang during X startup. Gnome panel visible, No background (b/w X11 background).
Obviously not all errors could be written to the log file.
Comment 4 Werner Gold 2008-12-07 15:58:34 EST
Created attachment 326055 [details]
Xorg.log  from "X" command

Issued "X" command from root at runlevel 3.
System here does not freeze completely, but terminating X leaves console unusable.
Immediate reboot necessary. This file shows more meaningful error messages than the one that tries to start Gnome completely and thus freezes the system.
Comment 5 Luis Villa 2009-01-09 06:52:26 EST
Dupe of bug 474327?
Comment 6 Werner Gold 2009-01-09 08:11:54 EST
Yes, looks like.
Comment 7 Werner Gold 2009-01-09 08:13:14 EST
BTW: "NoAccel" "True" works here as well. Beside the fact that it is no satisfying workaround
Comment 8 Matěj Cepl 2009-01-09 18:43:18 EST

*** This bug has been marked as a duplicate of bug 474327 ***

Note You need to log in before you can comment on or make changes to this bug.