Bug 475097 - Review Request: gimp-fourier-plugin - A fourier transformation plugin for GIMP.
Review Request: gimp-fourier-plugin - A fourier transformation plugin for GIMP.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 13:57 EST by Fabian Deutsch
Modified: 2009-02-01 13:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-01 13:52:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mtasaka: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2008-12-07 13:57:32 EST
Spec URL: http://www.informatik.uni-bremen.de/~fabiand/fedora/fourier/gimp-fourier-plugin.spec
SRPM URL: http://www.informatik.uni-bremen.de/~fabiand/fedora/fourier/gimp-fourier-plugin-0.3.1-1.fc9.src.rpm
Description: A simple plug-in to do fourier transform on you image. The major advantage of this plugin is to be able to work with the transformed image inside GIMP. You can so draw or apply filters in fourier space, and get the modified image with an inverse FFT.

This is my first package, so I need a sponsor.
Comment 1 Mamoru TASAKA 2009-01-18 12:31:16 EST
Well, I cannot see any license texts in this package.
Would you explain what file shows the license of this package?
Comment 2 Fabian Deutsch 2009-01-18 14:27:55 EST
I contacted the author, he'll include the missing license informations in the next release.
Comment 3 Mamoru TASAKA 2009-01-19 10:39:57 EST
(In reply to comment #2)
> I contacted the author, he'll include the missing license informations in the
> next release.

Does this mean that the upstream is going to release the new version
in a short time?
Comment 4 Fabian Deutsch 2009-01-19 17:05:20 EST
(In reply to comment #3)
> (In reply to comment #2)
> > I contacted the author, he'll include the missing license informations in the
> > next release.
> 
> Does this mean that the upstream is going to release the new version
> in a short time?

There was just a new version released upstream and updated the SRPM and spec files.
http://www.informatik.uni-bremen.de/~fabiand/fedora/fourier/gimp-fourier-plugin-0.3.2-1.fc9.src.rpm
http://www.informatik.uni-bremen.de/~fabiand/fedora/fourier/gimp-fourier-plugin.spec

As of http://bugzilla.gnome.org/show_bug.cgi?id=568351 I also introduced a small hack to get around it.

Koji scratch build ran fine.
http://koji.fedoraproject.org/koji/taskinfo?taskID=1067281
Comment 5 Mamoru TASAKA 2009-01-21 09:19:31 EST
! First of all:
  Please check your srpm / rebuilt binary rpms using "rpmlint"
  (in rpmlint rpm). This will detect some generic packaging errors.

For 0.3.2-1:
* odd issue in srpm
  - Please change the permissions of all files in srpm to 0644.

* disttag
  - Please consider to use %{?dist} tag:
    https://fedoraproject.org/wiki/Packaging/DistTag

* Macros in SourceURL
  - Using %{name}, %{version}, especially %{version} in SourceURL
    is recommended:
    https://fedoraproject.org/wiki/Packaging/SourceURL#Using_.25.7Bversion.7D

* Misc rpmlint issue
------------------------------------------------------------
W: summary-ended-with-dot A simple plug-in to do fourier transform on you image.
E: description-line-too-long A simple plug-in to do fourier ...
------------------------------------------------------------
  - Summary must not end with dot.
  - Please shorten the length of a line in %description. It should
    not exceed 79 characters.

* License
  - The licene tag "GPL" is invalid on Fedora.
    https://fedoraproject.org/wiki/Packaging/LicensingGuidelines#GPL_and_LGPL
    For this package the license tag should be "GPLv3+".

* (Build)Requires
  - Please check if "BuildRequires: gimp" is needed.
  - "Requires: fftw3" is definitely unneeded. Such library related
    dependencies are automatically detected by rpmbuild itself and
    rpmbuild correctly adds those dependencies.
    ! "Requires: gimp" is needed for this case because of directory
      ownership issue

* compiler flags
  - Fedora specific compiler flags are not honored correctly.
    https://fedoraproject.org/wiki/Packaging/Guidelines#Compiler_flags
    This can be specified by %optflags (you can check what compiler
    flags must be honored by $rpm --eval %optflags)
    ! As a result, currently debuginfo rpm creation is incomplete.

* $RPM_BUILD_ROOT vs %{buildroot}
  - Choose one. Please don't use both.

* Directory ownership issue
  - The directory %{_libdir}/gimp/2.0{,/plug-ins} themselves should not
    be owned by this package:
    https://fedoraproject.org/wiki/Packaging/Guidelines#File_and_Directory_Ownership

* Documents
  - Please add the following file(s) to %doc.
-------------------------------------------------
README
gpl.txt
-------------------------------------------------
    ! By the way README files are not in UTF-8, and this has
      CRLF, LF line terminators. Please fix these.

* %changelog
  - We recommend that one line is put between each %changelog entry
     (it will be helpful in Fedora CVS), like:
-------------------------------------------------
* Mon Jan 19 2009 Fabian Deutsch <fabian.deutsch at gmx.de> 0.3.2-1
- Updated to 0.3.2
- Includes license note
- Small hack around gimptool-2.0 bug.

* Sun Dec 07 2008 Fabian Deutsch <fabian.deutsch at gmx.de> 0.3.1-1
- Version 0.3.1
- Initial.
-------------------------------------------------
Comment 6 Fabian Deutsch 2009-01-22 15:15:47 EST
Okay. I went trough all those issues and solved them (and also try to remeber them :) ).

Except the optflag part. Could you give me a hint where are samples how to solve this?

Up to know I've put an updated version to 
http://www.informatik.uni-bremen.de/~fabiand/fedora/fourier/gimp-fourier-plugin-0.3.2-1.fc10.src.rpm
http://www.informatik.uni-bremen.de/~fabiand/fedora/fourier/gimp-fourier-plugin.spec
Comment 7 Mamoru TASAKA 2009-01-23 12:59:12 EST
From the next time please change the release number
every time you modify your spec file.

* Compiler flags
  - From Makefile and from what "man gimptool" says, for
    this package the following is simpler:
---------------------------------------------------------
%build
export CC="gcc %{optflags}"
make %{?_smp_mflags}
---------------------------------------------------------

* rpmlint issue
  - Now "README" file is not in UTF-8 yet. Please change the
    encoding of this file by iconv.

* Directory permission
---------------------------------------------------------
E: non-standard-dir-perm /usr/share/doc/gimp-fourier-plugin-0.3.2 0644
---------------------------------------------------------
  - Umm.. %defattr(0644,root,root,-) does not seem to work, perhaps
    rpm's bug. This should be either %defattr(-,root,root,-) (preferred)
    or %defattr(0644,root,root,0755)
Comment 8 Fabian Deutsch 2009-01-25 13:12:35 EST
I solved those two issues.
The included patch resolved - I actually don't know why - the non-standard-dir-perm error.

http://www.informatik.uni-bremen.de/~fabiand/fedora/fourier/gimp-fourier-plugin-0.3.2-2.fc9.src.rpm
http://www.informatik.uni-bremen.de/~fabiand/fedora/fourier/gimp-fourier-plugin.spec
Comment 9 Mamoru TASAKA 2009-01-26 13:23:43 EST
Okay, then:

-------------------------------------------------------------
NOTE: Before being sponsored:

This package will be accepted with another few (or no) work. 
But before I accept this package, someone (I am a candidate) 
must sponsor you.

Once you are sponsored, you have the right to review other 
submitters' review requests and approve the packages formally. 
For this reason, the person who want to be sponsored (like you) 
are required to "show that you have an understanding 
of the process and of the packaging guidelines" as is described
on :
http://fedoraproject.org/wiki/PackageMaintainers/HowToGetSponsored

Usually there are two ways to show this.
A. submit other review requests with enough quality.
B. Do a "pre-review" of other person's review request
   (at the time you are not sponsored, you cannot do
   a formal review)

When you have submitted a new review request or have pre-reviewed other 
person's review request, please write the bug number on this bug report 
so that I can check your comments or review request.

Fedora package collection review requests which are waiting for someone to
review can be checked on:
http://fedoraproject.org/PackageReviewStatus/NEW.html
(NOTE: please don't choose "Merge Review")


Review guidelines are described mainly on:
http://fedoraproject.org/wiki/Packaging/ReviewGuidelines
http://fedoraproject.org/wiki/Packaging/Guidelines
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets
------------------------------------------------------------
Comment 10 Fabian Deutsch 2009-01-26 18:06:02 EST
Okay.

Here's a second package: xmlenc, a java xml library.

https://bugzilla.redhat.com/show_bug.cgi?id=481667
Comment 11 Mamoru TASAKA 2009-01-29 13:08:57 EST
Now I will approve this package (xmlenc is now in good shape,
I am re-reviewing xmlenc now)

---------------------------------------------------------------
    This package (gimp-fourier-plugin) is APPROVED by mtasaka
---------------------------------------------------------------

Please follow the procedure written on:
http://fedoraproject.org/wiki/PackageMaintainers/Join
from "Install the Client Tools (Koji)".

Now I am sponsoring you.

If you want to import this package into Fedora 9/10, you also have
to look at
http://fedoraproject.org/wiki/Infrastructure/UpdatesSystem/Bodhi-info-DRAFT
(after once you rebuilt this package on koji Fedora rebuilding system).

If you have questions, please ask me.

Removing NEEDSPONSOR.
Comment 12 Fabian Deutsch 2009-01-29 15:31:25 EST
New Package CVS Request
=======================
Package Name: gimp-fourier-plugin
Short Description: A simple plug-in to do fourier transform on your image
Owners: fabiand
Branches: F-10
InitialCC: fabiand mtasaka
Comment 13 Kevin Fenzi 2009-01-30 01:39:28 EST
cvs done.
Comment 14 Fabian Deutsch 2009-02-01 13:52:25 EST
Included in cvs:
http://cvs.fedoraproject.org/viewvc/rpms/gimp-fourier-plugin/
Comment 15 Fabian Deutsch 2009-02-01 13:56:14 EST
At last found the right way to close this bug.

Note You need to log in before you can comment on or make changes to this bug.