Bug 475099 - Gradual slowdown and X lockups with ati radeon xpress 200
Gradual slowdown and X lockups with ati radeon xpress 200
Status: CLOSED DUPLICATE of bug 498457
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 14:39 EST by Henrik Nordström
Modified: 2009-06-30 05:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 05:18:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log with Radeon enabled. (228.38 KB, text/plain)
2008-12-07 14:39 EST, Henrik Nordström
no flags Details
Xorg log, with modesettings enabled (crashing) (35.10 KB, text/plain)
2009-03-10 05:15 EDT, Henrik Nordström
no flags Details
Xorg log, nomodesetting (starts) (142.25 KB, text/plain)
2009-03-10 05:16 EDT, Henrik Nordström
no flags Details
messages with modesetting enabled (crashing) (72.02 KB, text/plain)
2009-03-10 05:34 EDT, Henrik Nordström
no flags Details
messages with nomodesetting (x starts) (47.53 KB, text/plain)
2009-03-10 05:34 EDT, Henrik Nordström
no flags Details
lspci -vvv (17.63 KB, text/plain)
2009-03-10 05:36 EDT, Henrik Nordström
no flags Details
readeontool regs output (with nomodesetting) (509 bytes, text/plain)
2009-03-10 05:38 EDT, Henrik Nordström
no flags Details

  None (edit)
Description Henrik Nordström 2008-12-07 14:39:08 EST
Created attachment 326051 [details]
Xorg log with Radeon enabled.

Description of problem:

System unstable/slow and X often locks up at 100% CPU unkillable.

Version-Release number of selected component (if applicable):

kernel-2.6.27.5-117.fc10.x86_64
xorg-x11-drv-ati-6.9.0-61.fc10.x86_64

How reproducible:

Several times a day.

Steps to Reproduce:
1. Boot
2. Login
3. Work for a while. No specific trigger found. But often using firefox.
  
Actual results:

System slowdowns and often hung X with only pointer moving. Xorg not responding to "kill -9".


Expected results:

System to work smoothly, just as it does the first few minutes..

Additional info:

Chipset is ATI Radeon Xpress 200 (RS482) with embedded radeon graphics.

Now running with the radeon kernel module disabled, hoping this will improve stability. Only using 2D so DRI etc isn't important for me.
Comment 1 Henrik Nordström 2009-02-19 18:13:40 EST
Seems to be more stable these days. Have increased the amount of memory assigned to the chipset video, and up to date on updates. I think the big change was the increase in memory assigned to the chipsed for video, but there has been some lockups after that as well. I notice in dmesg output that it seems the increase in video memory activated some other memory manager for the video memory area.

But the system do feel noticeably slower than Fedora-7 which I ran earlier on this box. But that is another issue I guess.. Unfortunately I had to wipe the Fedora-7 partition some time ago due to space constraints so I can't give any objective measurements on the difference.
Comment 2 François Cami 2009-02-20 19:06:44 EST
Henrik,

Could you add dmesg and /var/log/Xorg.0.log as uncompressed text/pain attachments to this bug with the latest updates ?
Please also try with nomodeset in the kernel command line and report (adding the same dmesg and Xorg logs with nomodeset would be helpful as well).

Thanks

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Henrik Nordström 2009-03-10 05:14:11 EDT
Back on this. As I said earlier it's been working quite well for some time with modesetting and all. I even set the graphics memory down to 32MB to see if the problem would reappear but it has been working fine for some weeks.

However, after the updates yesterday X now no longer starts unless nomodesetting is used. I guess it also starts if I increase the video memory size again, but I don't really want to do that as the memory is needed for other stuff..


Xorg.0.log files coming shortly.
Comment 4 Henrik Nordström 2009-03-10 05:15:32 EDT
Created attachment 334609 [details]
Xorg log, with modesettings enabled (crashing)
Comment 5 Henrik Nordström 2009-03-10 05:16:25 EDT
Created attachment 334610 [details]
Xorg log, nomodesetting (starts)
Comment 6 Henrik Nordström 2009-03-10 05:34:03 EDT
Created attachment 334611 [details]
messages with modesetting enabled (crashing)
Comment 7 Henrik Nordström 2009-03-10 05:34:42 EDT
Created attachment 334612 [details]
messages with nomodesetting (x starts)
Comment 8 Henrik Nordström 2009-03-10 05:36:07 EDT
Created attachment 334613 [details]
lspci -vvv
Comment 9 Henrik Nordström 2009-03-10 05:38:37 EDT
Created attachment 334614 [details]
readeontool regs output (with nomodesetting)
Comment 10 Henrik Nordström 2009-03-10 05:52:13 EDT
System fully up to date as of today.

Relevant package versions:

xorg-x11-drv-ati-6.10.0-2.fc10.x86_64
xorg-x11-drivers-7.3-9.fc10.x86_64
xorg-x11-server-Xorg-1.5.3-13.fc10.x86_64
libdrm-2.4.0-0.21.fc10.x86_64
kernel-2.6.27.19-170.2.35.fc10.x86_64
Comment 11 Matěj Cepl 2009-06-30 05:18:54 EDT

*** This bug has been marked as a duplicate of bug 498457 ***

Note You need to log in before you can comment on or make changes to this bug.