Bug 475130 - Negative preferred lifetimes of IPv6 prefixes/addresses displayed incorrectly
Summary: Negative preferred lifetimes of IPv6 prefixes/addresses displayed incorrectly
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: iproute
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-12-08 03:06 UTC by Benedikt Gollatz
Modified: 2009-01-21 21:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-21 21:25:39 UTC


Attachments (Terms of Use)
patch fixing broken preferred lifetime display (882 bytes, patch)
2008-12-08 03:06 UTC, Benedikt Gollatz
no flags Details | Diff

Description Benedikt Gollatz 2008-12-08 03:06:33 UTC
Created attachment 326072 [details]
patch fixing broken preferred lifetime display

Description of problem:

When the preferred lifetime of a prefix assigned by IPv6 autoconfiguration (router solicitation) becomes negative 

Version-Release number of selected component (if applicable):

Version    : 2.6.26
Release    : 1.fc10

How reproducible:

Always.

Steps to Reproduce:
1. Configure an IPv6 router to advertise a prefix with a short preferred lifetime, e.g. 0.
2. Wait for the IPv6 autoconfiguration process to complete for an interface <if> connected to a link where that router advertises.
3. Run ip -6 show dev <if>.
  
Actual results:

The preferred lifetime will have become negative, but it is printed as an unsigned integer. The preferred lifetime to be displayed will therefore be close to UINT_MAX.

Expected results:

The printed preferred lifetime should be negative for deprecated prefixes.

Additional info:

The attached patch fixes the problem.

Comment 1 Marcela Mašláňová 2008-12-09 14:04:35 UTC
If you are interested, you can send your patch directly to the upstream to netdev@vger.kernel.org or I can send it for you.

Comment 2 Benedikt Gollatz 2008-12-09 22:12:22 UTC
Well, actually I've contacted them a couple of months ago, because I think there is some confusion in the kernel APIs regarding this matter (see <http://bugzilla.kernel.org/show_bug.cgi?id=10880>), but nobody seemed interested. It looks like developers must make the distinction I implement in the fix themselves.

I'm going to send the iproute2 maintainer a pointer to this bug report.

Comment 3 Benedikt Gollatz 2008-12-09 23:36:41 UTC
Stephen Hemminger also relayed me to the netdev mailing list, so that's where I've sent the patch now.

Comment 4 Marcela Mašláňová 2008-12-10 08:35:23 UTC
Ok, thank you. I hope someone review it soon on the list.

Comment 5 Benedikt Gollatz 2009-01-08 14:09:33 UTC
The patch has been incorporated into the official git tree and Stephen Hemminger told me that it would be in the 2.6.28 version of iproute2.

Comment 6 Fedora Update System 2009-01-12 09:23:51 UTC
iproute-2.6.27-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/iproute-2.6.27-2.fc10

Comment 7 Benedikt Gollatz 2009-01-12 09:50:42 UTC
2.6.27-2.fc10 solved the problem for me.

Comment 8 Fedora Update System 2009-01-15 02:52:58 UTC
iproute-2.6.27-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update iproute'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0373

Comment 9 Fedora Update System 2009-01-21 21:25:36 UTC
iproute-2.6.27-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.