Bug 475177 - Multipath support for root partition on CCISS devices
Multipath support for root partition on CCISS devices
Status: CLOSED DUPLICATE of bug 484419
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
5.2.z
All Linux
low Severity high
: rc
: ---
Assigned To: Ben Marzinski
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 06:17 EST by vijay
Modified: 2010-05-12 13:58 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-12 13:58:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vijay 2008-12-08 06:17:12 EST
Description of problem:

The mpath devices are not created for cciss devices. Due to this the multipath support for the root partition on CCISS devices is not available.

How reproducible:
Providing the "mpath" kernel parameter at the installation prompt fails to create the multipath devices for the CCISS devices.

Expected results:
To include a patch to installation binary, to create the device mapper multipath devices for CCISS devices. 

Additional info:
Comment 1 Senthil Kumar V 2009-06-11 02:57:02 EDT
Is there any update on this issue?
Comment 2 Senthil Kumar V 2009-07-09 07:40:53 EDT
Any updates on this? Has this been fixed in RHEL5.4 beta?
Comment 3 Ben Marzinski 2009-07-10 14:18:46 EDT
Is the lack of cciss devices due to bz #484419?
Comment 4 Bryn M. Reeves 2009-07-10 14:35:06 EDT
That's one of the blockers but there are probably other changes needed in mkinitrd and maybe anaconda (afaik cciss still needs a separate cciss_id WWID callout).
Comment 6 Ben Marzinski 2010-04-27 13:45:50 EDT
the device-mapper-multipath package already provides a cciss_id callout.
/sbin/cciss_id.

Unless someone has a specific reason why we need this bugzilla, I'm going to close it as a dup of bz #484419.
Comment 7 Ben Marzinski 2010-05-12 13:58:02 EDT
I'm closing this as a dup of 484419.  If there are specific device-mapper-multipath problems with cciss devices, feel free to reopen this bug with a comment explaining them.

*** This bug has been marked as a duplicate of bug 484419 ***

Note You need to log in before you can comment on or make changes to this bug.