Bug 475183 - yum erase cause problem when solving dependencies
yum erase cause problem when solving dependencies
Status: CLOSED DUPLICATE of bug 448153
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rpm (Show other bugs)
5.3
ia64 Linux
medium Severity medium
: rc
: ---
Assigned To: Panu Matilainen
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 07:19 EST by Jan Ščotka
Modified: 2008-12-08 10:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 10:01:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum erase zip - log (20.74 KB, text/plain)
2008-12-08 07:19 EST, Jan Ščotka
no flags Details
yum install tomcat5 - log (503 bytes, text/plain)
2008-12-08 07:21 EST, Jan Ščotka
no flags Details
package-cleanup --problem - log (2.99 KB, text/plain)
2008-12-08 07:22 EST, Jan Ščotka
no flags Details

  None (edit)
Description Jan Ščotka 2008-12-08 07:19:54 EST
Created attachment 326119 [details]
yum erase zip - log

Description of problem:
Problems appeared on various system, not only ia64, but there it had problems when install software back. When uninstalling program "zip" many bugs in uninstalling process.
It causes, that tomcat5 cannot be installed back.
It seems to be /usr/bin/rebuild-gcj-db (java-1.4.2-gcj-compat) missing, because gcj is uninstalled before should be uninstalled.

Problems are in dependencies solving erase process. It isn't problem only tomcat5 application suite, but various java applications.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. yum install tomcat5
2. yum remove zip
3. yum install tomcat5
 
then try package-cleanup --problem commnad and you shlould se unsolved dependencies for tomcat5. Tomcat is already installed.

 
Actual results:
>> logs in attachment

on i386 (without problems with install back)
Running Transaction
  Erasing        : libgcj                                          [ 1/40] 
warning: /usr/lib/security/classpath.security saved as /usr/lib/security/classpath.security.rpmsave
  Erasing        : tomcat5-common-lib                              [ 2/40] 
/usr/bin/rebuild-gcj-db: line 6: /usr/bin/gcj-dbtool: No such file or directory
dirname: missing operand
Try `dirname --help' for more information.

mkdir: missing operand


Expected results:
without problems when erasing packages

Additional info:
Comment 1 Jan Ščotka 2008-12-08 07:21:27 EST
Created attachment 326120 [details]
yum install tomcat5 - log
Comment 2 Jan Ščotka 2008-12-08 07:22:24 EST
Created attachment 326121 [details]
package-cleanup --problem - log
Comment 3 James Antill 2008-12-08 09:30:48 EST
So this bug is about the ordering of the erase transaction, yes?

What is getting erased, and what needs to be erased for dependencies ... is correct?

Reassigning to rpm, if I've screwed up what the problem is ... please assign back.
Comment 4 Jan Ščotka 2008-12-08 09:43:45 EST
Yes, I thing, problem is, that yum do not resolve dependencies in right way.
java-1.4.2-gcj-compat should be erased at the end, not before uninstalling tomcat or other java libraries.
Comment 5 Panu Matilainen 2008-12-08 10:01:58 EST

*** This bug has been marked as a duplicate of bug 448153 ***
Comment 6 James Antill 2008-12-08 10:18:02 EST
 The packages looks right, it has:

Requires(post):         java-gcj-compat >= 1.0.31
Requires(postun):       java-gcj-compat >= 1.0.31

...which is provided by java-1.4.2-gcj-compat-1.4.2.0-40jpp.115, which provides /usr/bin/rebuild-gcj-db.

Note You need to log in before you can comment on or make changes to this bug.