Bug 475193 - Hardware direct rendering lost after resume for ATI Radeon X800 (R430) and 2.6.28 kernels
Hardware direct rendering lost after resume for ATI Radeon X800 (R430) and 2....
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 08:22 EST by Joachim Frieben
Modified: 2018-04-11 11:55 EDT (History)
5 users (show)

See Also:
Fixed In Version: kernel-PAE-2.6.29-0.176.rc6.git5.fc11.i686
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-14 08:22:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace in /var/log/dmesg after resume from suspend (1.61 KB, text/plain)
2008-12-08 08:22 EST, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2008-12-08 08:22:44 EST
Created attachment 326129 [details]
Backtrace in /var/log/dmesg after resume from suspend

Description of problem:
After resuming from suspend for kernel 2.6.28-0.114.rc7.git5.fc11.x86_64, only software direct rendering is available for an ATI Radeon X800 (R430) whereas before suspending the system, the Mesa DRI R300 renderer was active.

Version-Release number of selected component (if applicable):
kernel-2.6.28-0.114.rc7.git5.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Suspend system from running GNOME session.
2. Resume.
3. Execute 'env LIBGL_DEBUG=verbose glxinfo'.
  
Actual results:
Active renderer is Mesa DRI R300.

Expected results:
Active renderer is Mesa Software Rasterizer.

Additional info:
- glxinfo reports 'drmMap failure'.
- one kernel oops occurs before suspend in dmesg, a second one with a
  complete backtrace (attached) after resume.
- kernel-2.6.28-* are the first ones since 2.6.25.x which allow to
  (partially) successfully resume from suspend (bug 469580).
Comment 1 Joachim Frieben 2008-12-08 08:26:24 EST
Actual results:
Active renderer is Mesa Software Rasterizer.

Expected results:
Active renderer is Mesa DRI R300.

.. this looks more sensible.
Comment 2 Frank Schmitt 2009-01-23 09:32:57 EST
I see the same problem on a Thinkpad R52 with a
VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]

under Fedora 8 everything (suspend, resume and DRI) worked nicely, after I installed F10 and all updates I only get software rendering after suspend.
Comment 3 Dave Airlie 2009-01-24 18:55:07 EST
I've just submitted a build to koji

it'll show up at

http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-ati/6.9.0/64.fc10/

please test it.
Comment 4 Joachim Frieben 2009-01-25 13:22:56 EST
I had reverted my system to F10 some time ago, and here, the issue actually actually even showed up for kernel 2.6.27.x. However, upgrading to xorg-x11-drv-ati-6.9.0-64.fc10.x86_64 does solve the issue. Thanks!
Comment 5 Frank Schmitt 2009-01-25 13:47:22 EST
The package in koji breaks my system. That means after first bot everything is ok as with the old package, however if I use dri after suspend, my computer freezes completely.

[~]$ uname -a
Linux glasgow.frank-schmitt.net 2.6.27.9-159.fc10.i686 #1 SMP Tue Dec 16 15:12:04 EST 2008 i686 i686 i386 GNU/Linux
[~]$ /sbin/lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]
Comment 6 Joachim Frieben 2009-01-25 14:33:24 EST
Have you tried kernel-2.6.27.12-170.2.5.fc10.x86_64 and/or the latest 6.10 package? Available respectively at:

  http://kojipkgs.fedoraproject.org/packages/xorg-x11-drv-ati/6.10.0/1.fc10/
  http://kojipkgs.fedoraproject.org/packages/kernel/2.6.27.12/170.2.5.fc10/
Comment 7 Jon Escombe 2009-01-29 06:25:14 EST
As per comment #5, this update also breaks for me. Before this I could resume with software rendering, but now I get a hang when using DRI.

Lenovo T60, Radeon Mobility X1400
kernel-2.6.27.12-170.2.5.fc10.i686
xorg-x11-drv-ati-6.9.0-64.fc10.i386 / xorg-x11-drv-ati-6.10.0-1.fc10.i386
Comment 8 Joachim Frieben 2009-01-31 00:45:20 EST
X definitely locks up when calling "glxgears" a second time after resuming from suspend for the latest F10 kernel packages from the 2.6.27.x and 2.6.29 branches, respectively:
- kernel-2.6.27.12-170.2.5.fc10.x86_64
- kernel-2.6.29-0.6.rc3.fc10.x86_64
Comment 9 Joachim Frieben 2009-02-01 04:20:37 EST
No improvement with the latest koji builds:

- kernel-2.6.27.14-170.2.10.rc1.fc10.x86_64
- xorg-x11-drv-ati-6.10.0-2.fc10.x86_64

Interestingly, X only locks up after resume when direct rendering had been used before suspending the system, e.g. running "glxgears" both before and after suspend. Running "glxgears" ony after resuming from suspend does not cause any problem.
Comment 10 Joachim Frieben 2009-02-09 05:22:42 EST
X locks for kernel-2.6.29-0.22.rc4.git1.fc10.x86_64, too, when "glxgears" is executed after resume from suspend and had already been called before suspending the system.

- kernel-2.6.29-0.22.rc4.git1.fc10.x86_64
- xorg-x11-drv-ati-6.10.0-2.fc10.x86_64
Comment 11 Nigel Jones 2009-02-16 18:57:00 EST
I've had this on x86 under #475193
Comment 12 Joachim Frieben 2009-02-16 23:08:40 EST
But this -is- bug 475193!
Comment 13 Nigel Jones 2009-02-17 02:39:25 EST
Sorry that is bug 476594
Comment 14 Joachim Frieben 2009-02-21 02:34:27 EST
Excellent! Regarding 2.6.27.x kernels, the latest Koji build kernel-2.6.27.19-170.2.30.rc1.fc10.x86_64 solves the problem where X would lock up the system when "glxgears" was executed a second time after resume from suspend.
- kernel-2.6.27.19-170.2.30.rc1.fc10.x86_64
- xorg-x11-drv-ati-6.10.0-2.fc10.x86_64
Comment 15 Joachim Frieben 2009-02-26 13:53:06 EST
I do not encounter any X issues related to suspend/hibernate anymore.
- kernel-2.6.27.19-170.2.35.fc10.x86_64
- kernel-2.6.29-0.43.rc6.fc10.x86_64
- xorg-x11-drv-ati-6.10.0-2.fc10.x86_64
Comment 16 Nigel Jones 2009-03-02 15:05:29 EST
Seems to be working for me now with
Now seems to be working with
xorg-x11-server-Xorg-1.6.0-2.fc11.i586
kernel-PAE-2.6.29-0.176.rc6.git5.fc11.i686
compiz-0.7.8-14.fc11.i586
xorg-x11-drv-ati-6.11.0-1.fc11.i586



for the first time since F9 :-)
Comment 17 Matěj Cepl 2009-10-14 08:22:00 EDT
Thanks for letting us now.

Note You need to log in before you can comment on or make changes to this bug.