Bug 475206 - Sound crackles with SDL_mixer using programs
Sound crackles with SDL_mixer using programs
Status: CLOSED DUPLICATE of bug 474450
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 09:51 EST by Hans de Goede
Modified: 2008-12-08 14:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 14:32:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-12-08 09:51:50 EST
Description of problem:
The sound crackles when using SDL_mixer using programs, see bug 474745. I can reproduce this on my fully up2date F-10 x86_64 system.

The funny thing is if I edit /etc/pulse/daemon.conf and then
uncomment these 2 lines:

realtime-scheduling = yes  
realtime-priority = 5  

And then kill pulseaudio and restart it, the problem goes away. Even though when started from a terminal pulseaudio complains it cannot get RT permission and according to top, indeed it has not gotten realtime permission.

This is not a glitch, re-commenting the lines and restarting pa again, reintroduces the crackling. The crackling happens the most with certain usage patterns. For example hovering the mouse over the X to close a window, so that it gets highlighted, causes the crackle. Note I'm not using compiz, just plain metacity.

It seems that these 2 config options change pa's behavior in some (possitive) way even if it could not get RT priority.

To reproduce do "yum install creack-attack" and then either start crack-attack, or play its music using the SDL_mixer cmdline player:
playmus /usr/share/crack-attack/music/prelude.xm
Comment 1 Lennart Poettering 2008-12-08 14:32:01 EST

*** This bug has been marked as a duplicate of bug 474450 ***

Note You need to log in before you can comment on or make changes to this bug.