Bug 475214 - segfault during removal of jclasslib/jprofiler rpms
segfault during removal of jclasslib/jprofiler rpms
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 10:14 EST by Christoph Walter
Modified: 2009-01-08 14:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 04:20:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output of the command (97.25 KB, application/zip)
2008-12-08 10:15 EST, Christoph Walter
no flags Details

  None (edit)
Description Christoph Walter 2008-12-08 10:14:35 EST
rpm segfaults during the removal of these two rpms.

command:

# rpm -e jclasslib

Please have a look at the logfile attached.
Comment 1 Christoph Walter 2008-12-08 10:15:21 EST
Created attachment 326135 [details]
strace output of the command
Comment 2 Christoph Walter 2008-12-08 10:18:33 EST
I tried to rebuild the rpmdb but that didn't solve the problem
Comment 3 Panu Matilainen 2008-12-08 11:53:58 EST
Neither package is in Fedora, you're talking about the packages from http://www.ej-technologies.com/ right? The packages are built with some "creatively" modified rpm apparently but no excuse for crashing, will fix...
Comment 4 Christoph Walter 2008-12-08 12:17:18 EST
Yes you're right the package is from ej-technologies.com. 
I installed them with fc9, after upgrading to fc10 rpm/yum segfaults and I'm not able to get rid of the packages anymore.
Tanks for help in advance.
Comment 5 Panu Matilainen 2008-12-08 13:00:59 EST
Ok, thanks for confirming that. This is now fixed upstream, along with some other issues caused by the weirdo packages, will be in Fedora shortly.

In the meanwhile, you can probably get rid of the packages by using --noscripts option as a workaround.
Comment 6 Jeff Johnson 2008-12-08 13:35:25 EST
The weirdo packages are quite strange, not produced by
any rpmbuild I'm aware of because missing
    RPMTAG_RPMVERSION
and
    RPMTAG_SPURCEPACKAGE
tags. The lack of RPMTAG_SOURCEPACKAGE also
prevents header from being registered in rpmdb @rpm5.org,
so --erase segfaults are (by definition) impossible.

Perhaps jrpm produced ...

And LSB also has its own speshul perl script to produce
*.rpm packages that have randomly missing tag content.

So much for "standard" RPM packaging, software distribution
will sink back into tar/cpio archives instead of packages Real
Soon Now imho.
Comment 7 Christoph Walter 2008-12-09 04:21:30 EST
Thanks god the --noscript option made my day :-)

Thanks for the quick help!!
Comment 8 Fedora Update System 2008-12-12 14:14:19 EST
rpm-4.6.0-0.rc3.1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rpm-4.6.0-0.rc3.1.fc10
Comment 9 Fedora Update System 2008-12-17 19:34:21 EST
rpm-4.6.0-0.rc3.1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11332
Comment 10 Fedora Update System 2009-01-07 04:20:20 EST
rpm-4.6.0-0.rc3.1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.