Bug 47522 - gdm "faces" shows rpm user
Summary: gdm "faces" shows rpm user
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdm   
(Show other bugs)
Version: 7.3
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-05 21:31 UTC by Joshua Jensen
Modified: 2007-03-27 03:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-06 15:08:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Jensen 2001-07-05 21:31:51 UTC
I used gdmconfig to enable the "faces" feature during gdm log in.  However,
gdm shows the "rpm" user, along with standard users and root.  Seems like
this shouldn't be.  Grep'ing through /etc/passwd, it looks like gdm is
showing any user with a real (non-false) shell.  RPM has it's shell of
/bin/bash (is this as intented?), as shows up in gdm.  Not a big bug, but
maybe gdm should only show "faces" for users of UID 500 and above?

Joshua

Comment 1 Havoc Pennington 2001-07-06 02:30:22 UTC
You give gdm too much credit ;-) It just has a list of users not to show, in
/etc/X11/gdm/gdm.conf

I'll add the rpm user.

Comment 2 Joshua Jensen 2001-07-06 15:08:12 UTC
Cool.. thanks.  However, it is a never ending battle if you have to explicitly
block each user... maybe a blocked-UID range is a more permanent answer for the
future.

Joshua

Comment 3 Havoc Pennington 2001-07-12 19:17:12 UTC
Fixed


Note You need to log in before you can comment on or make changes to this bug.