Bug 475239 - Polish language support is missing in anaconda, when installation in English
Polish language support is missing in anaconda, when installation in English
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 11:43 EST by markm
Modified: 2014-01-21 18:03 EST (History)
4 users (show)

See Also:
Fixed In Version: anaconda-14.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-05 09:50:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda - missing English British language support (145.38 KB, image/png)
2009-03-12 11:07 EDT, markm
no flags Details
anaconda - missing Polish language support (147.10 KB, image/png)
2009-03-12 11:09 EDT, markm
no flags Details

  None (edit)
Description markm 2008-12-08 11:43:37 EST
Description of problem:

When I do installation of Fedora 10, support for English UK and Polish are missing from anaconda. 

Version-Release number of selected component (if applicable):

Fedora-10-DVD.iso

How reproducible:

always (checked on 2 machines and in virtual machine)

Steps to Reproduce:
1. Start installation
2. Select installation language as English
3. Customise packages, select Languages
  
Actual results:

Polish and English UK are missing

Expected results:

Polish and English UK available to install

Additional info:

Fedora installs bunch of Chinese, Thai, Japan fonts by default... when they are not needed - Firefox for example has plugins to support almost all languages but Polish and English UK - it looks like it's a big mess, do we really need Asian languages support when installation is done in English? these packages should be optional, not installed by default.
Comment 1 markm 2009-03-12 11:07:53 EDT
Created attachment 334943 [details]
anaconda - missing English British language support
Comment 2 markm 2009-03-12 11:09:14 EDT
Created attachment 334944 [details]
anaconda - missing Polish language support
Comment 3 markm 2009-03-12 11:09:52 EDT
looking at the anaconda right now I can say - many languages are missing from the list.
Comment 4 Bill Nottingham 2009-03-12 12:46:56 EDT
No packages for these groups are on the DVD, so the group isn't shown.
Comment 5 markm 2009-03-12 13:17:53 EDT
Looking at Fedora-10-i386-DVD.iso I can see:

hunspell-pl-0.20080823-1.fc10.noarch.rpm :)

so I guess, it should be a part of “Polish support”, right?

also, if there is no “Polish language” support, does it get installed automatically?

and what is the point of installing all languages when I know I will use only Polish and English UK?

and why for example Firefox has 30+ language packs installed by default when I don't want to use them?
Comment 6 Jeroen van Meeuwen 2009-03-15 00:00:28 EDT
Polish support is included on the installation media:

http://git.fedorahosted.org/git/?p=spin-kickstarts.git;a=blob;f=fedora-install-fedora.ks;h=62d7c048f2e05f8c4b2fb4fefaa8aa9c7c5c3470;hb=22b216589aae1c5d1cc6b9f5ff4e97f95009032b#l139

As is British support:

http://git.fedorahosted.org/git/?p=spin-kickstarts.git;a=blob;f=fedora-install-fedora.ks;h=62d7c048f2e05f8c4b2fb4fefaa8aa9c7c5c3470;hb=22b216589aae1c5d1cc6b9f5ff4e97f95009032b#l87

This is definitely not a spin-kickstarts bug. I'm not sure though where this bug belongs but I'm hoping it'll get reassigned as we figure it out.
Comment 7 Bill Nottingham 2009-03-16 12:33:43 EDT
Hm, looking at the Polish group, all packages are either:

1) optional (which wouldn't be in the installation media, IIRC)
2) conditional on other packages (which therefore aren't selectable)

So, I believe anaconda is acting as-programmed, in that there are no user selectable packages in the group, so the group isn't selectable.

Should groups with only conditional packages be selectable?
Comment 8 markm 2009-03-16 12:48:08 EDT
(In reply to comment #7)
> Hm, looking at the Polish group, all packages are either:
> 
> 1) optional (which wouldn't be in the installation media, IIRC)
> 2) conditional on other packages (which therefore aren't selectable)
> 
> So, I believe anaconda is acting as-programmed, in that there are no user
> selectable packages in the group, so the group isn't selectable.
> 
> Should groups with only conditional packages be selectable?  

from end user point of you at least I should be able to see these preselected packages - my first though was “these languages are missing” - so it's confusing.

another thing is - why does anaconda install many languages? not sure if they take lots of space, but for example in Firefox I've got almost all languages installed even if I don't want to, in pidgin I can see dictionaries for all English versions even if I want just British... IMHO it looks like a big mess.
Comment 9 Bug Zapper 2009-06-09 06:10:27 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 markm 2009-06-25 23:58:40 EDT
(In reply to comment #7)
> Hm, looking at the Polish group, all packages are either:
> 
> 1) optional (which wouldn't be in the installation media, IIRC)
> 2) conditional on other packages (which therefore aren't selectable)
> 
> So, I believe anaconda is acting as-programmed, in that there are no user
> selectable packages in the group, so the group isn't selectable.
> 
> Should groups with only conditional packages be selectable?  

I have just installed Fedora 11 on my laptop - did installation in English with Polish keyboard selected. I could not select “Polish language support”, then:

1. I fired up Evolution - I cannot spell check in Polish (though I can in all English variants).
2. I switched to Polish on the login screen, everything was in Polish, but man pages were missing (English one displayed instead of).
3. I fired up OpenOffice and wanted to write a document in Polish - there was no spell check for Polish language.

Quick look at repositories and I found following packages missing:

∘ aspell
∘ aspell-pl
∘ autocorr-pl
∘ hunspell-pl
∘ hypen-pl
∘ man-pages-pl
∘ openoffice.org-langpack-pl_PL

which I had to install manually.

So from my perspective - there should be an option in anaconda “Polish language support” which would install this packages for me during installation process.

When I think about “Polish language support” I don't mean only labels, but full support - with dictionaries, man pages etc.
Comment 12 markm 2009-11-04 10:27:30 EST
Fedora 12 Beta installation from dvd-iso - support for Polish language is still missing.
Comment 13 Bug Zapper 2009-11-16 04:42:52 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Bill Nottingham 2010-01-20 14:27:19 EST
Moving back to anaconda; any change to make groups with only conditional packages selectable would have to be made there.
Comment 15 Chris Lumens 2010-03-16 13:46:00 EDT
I have no plans to change the behavior of conditional packages in anaconda.  Really, anaconda is set up with a strong tie between the installation language and the post-installation runtime language.  If you require a Polish runtime, please do an install in Polish.
Comment 16 markm 2010-03-16 21:31:10 EDT
(In reply to comment #15)
> I have no plans to change the behavior of conditional packages in anaconda. 
> Really, anaconda is set up with a strong tie between the installation language
> and the post-installation runtime language.  If you require a Polish runtime,
> please do an install in Polish.    

Thank you for your kind reply. Let me explain you my user case, which may be applicable to many users:

1. I user system in English (UK) and as far as I am aware, I cannot select that particular language in anacona - of course I can select English, select my location, but then by default I have English (United States). Fail one.

2. Even if I select English, I have no way to add British support - no offence, but English does not mean United States - I understand the reason everything is by default US English, though that approach lacks respect to other English speaking countries.

3. I am native Polish speaker and require support for Polish language, as I need to write documents in Polish. Please understand - I do not want to have menus in Gnome translated to Polish as I don't find this translation useful and I work and live in United Kingdom, it's easier for me to work that way. Fail three.

4. I learn Spanish and from time to time I need to write an essay or prepare a project... in Spanish - that would be really useful, if I could install Spanish support while installing my system. Fail four.

5. Even if do installation in Polish, I still cannot add support for British or Spanish, if I do installation in Spanish, I still cannot add support for British or Polish... Fail five.

What does anaconda offer at the moment?

* it installs by default bunch of useless (to me) packages like Asian fonts, which I don't need, won't use and don't require.
* it allows me to install support for many Asian languages and not only Asians ones, yet it does not allow me to install Polish or Spanish support.
* when I start “add/remove packages” after install, yes, I can see “polish-support” and “spanish-support” which makes it convenient to install, but it rises the question - why those packages are available on the runtime, but not while installation?

to me your “behaviour of conditional packages” is wrong, at least when it comes to languages.

of course installation of additional packages is not a big issue unless you're travelling with your netbook and suddenly realises that you: a) need to download polish dictionary b) you are abroad c) and have only broadband mobile which costs a lot - sounds crazy, but it actually has happened to me. If had have an option to add language support on the installation, I would not have forgotten to install it in a first place.

Please note, it used to work well in earlier versions of Fedora - behaviour has changed and is causing trouble to users.
Comment 17 Chris Lumens 2010-03-17 09:56:45 EDT
> 1. I user system in English (UK) and as far as I am aware, I cannot select that
> particular language in anacona - of course I can select English, select my
> location, but then by default I have English (United States). Fail one.

anaconda does not include support for every single language, no.  However the translation files for every language should get installed when you install a package, and you can readily change your language post-installation so this should not be a problem for you.

> 2. Even if I select English, I have no way to add British support - no offence,
> but English does not mean United States - I understand the reason everything is
> by default US English, though that approach lacks respect to other English
> speaking countries.

The british-support group only includes conditional KDE packages.  If you're not installing KDE, you're not going to get those packages.

> 3. I am native Polish speaker and require support for Polish language, as I
> need to write documents in Polish. Please understand - I do not want to have
> menus in Gnome translated to Polish as I don't find this translation useful and
> I work and live in United Kingdom, it's easier for me to work that way. Fail
> three.

Sorry, we do not support this use case.  As I previously explained, anaconda has a strong tie between the installation language and the runtime language.

> 4. I learn Spanish and from time to time I need to write an essay or prepare a
> project... in Spanish - that would be really useful, if I could install Spanish
> support while installing my system. Fail four.

Again, the spanish-support language group contains largely conditional packages.  If you aren't installing the packages those are predicated upon, you're not going to get them either.

> 5. Even if do installation in Polish, I still cannot add support for British or
> Spanish, if I do installation in Spanish, I still cannot add support for
> British or Polish... Fail five.

I've explained this several times now, and I don't really care about your score keeping there.

> * it installs by default bunch of useless (to me) packages like Asian fonts,
> which I don't need, won't use and don't require.
> * it allows me to install support for many Asian languages and not only Asians
> ones, yet it does not allow me to install Polish or Spanish support.

This is because of the ridiculous way that input method selection works right now.  See bug 514157.

> * when I start “add/remove packages” after install, yes, I can see
> “polish-support” and “spanish-support” which makes it convenient to install,
> but it rises the question - why those packages are available on the runtime,
> but not while installation?

Because it's a completely different program with a completely different concept of how things should work.
Comment 18 markm 2010-03-17 17:00:01 EDT
(In reply to comment #17)
> (cut)
> I've explained this several times now, and I don't really care about your score
> keeping there.

Thank you for your brilliant notes, shame you didn't answer to that one:

> of course installation of additional packages is not a big issue unless you're
travelling with your netbook and suddenly realises that you: a) need to
download polish dictionary b) you are abroad c) and have only broadband mobile
which costs a lot - sounds crazy, but it actually has happened to me. If had
have an option to add language support on the installation, I would not have
forgotten to install it in a first place.

basically anaconda should allow install support for other languages or it should be possible to install them from the media after installation. the core point is - there is no option to install it at the moment if you have NO internet connection. but you don't care, you think about just one simple user case, you don't care about other user cases. keep it simple stupid - right? so allow to install at least dictionaries, because it is not possible right now. honestly I don't care about full language support, but at least dictionaries should be selectable during the installation process. Is it difficult to understand, that some people are not “english-only”? how many people use Fedora in US? how many people use Fedora outside US?

Note You need to log in before you can comment on or make changes to this bug.