Bug 475358 - [LTC 5.6 FEAT] Adjust Anaconda Swap recommendations to Linux on System z specifics [201680]
[LTC 5.6 FEAT] Adjust Anaconda Swap recommendations to Linux on System z spec...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.6
s390x All
high Severity high
: beta
: 5.6
Assigned To: David Cantrell
Release Test Team
: FutureFeature, OtherQA, Reopened
: 511985 566197 (view as bug list)
Depends On:
Blocks: 557597 600484
  Show dependency treegraph
 
Reported: 2008-12-08 17:40 EST by IBM Bug Proxy
Modified: 2013-07-11 20:03 EDT (History)
12 users (show)

See Also:
Fixed In Version: anaconda-11.1.2.213-1
Doc Type: Enhancement
Doc Text:
The swap space required by a system running Red Hat Enterprise Linux 5 varies according to the role of the system. Previously, anaconda recommended that all installations on IBM System z required swap space at least equal to the amount of installed system memory. This recommendation could have misled users to allocate far more swap space than was required for their purposes. Anaconda now warns users only if they have not allocated any swap space at all. Users can therefore allocate swap space appropriate to their systems without potentially misleading warnings from anaconda.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 16:52:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 50345 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-12-08 17:40:47 EST
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201680]
a. Name of Feature:	Adjust Anaconda Swap recommendations to Linux on System z specifics
b. Feature Description
If the configured size of swap is less than the main memory (storage), anaconda shows an information
box stating that this may influence performance and whether the user wants to continue or change the
swap configuration. Additionally, the System z specific section 17.14.4 in the RHEL 5.1 Install
Guide states rules of thumbs for swap size which seem to have been taken from the description for
the x86 architecture. However, in VM environments, rules for determining the swap size are not as
simple as on x86.
 
 1) The above mentioned anaconda info box should not appear on s390.
 
 2) The content of Section 17.14.4 of the RHEL 5.1 Install Guide should be replaced by:
 'Configuring efficient swap space for Linux on System z is a complex 
 task. It very much depends on the specific environment and should be
 tuned to the actual system load.
 
 Please see the following resources for more information:
 * Chapter 7 on 'Linux swapping' of the IBM Redbook, Linux on IBM System z: Performance Measurement
and Tuning, IBM Form Number SG24-6926-01, ISBN 0738485586. [
http://www.redbooks.ibm.com/abstracts/sg246926.html ]
 * topic 'Linux on System z performance' in the IBM Systems Information Center [
http://publib.boulder.ibm.com/infocenter/systems/index.jsp?topic=/liaag/lcon_Linux_on_System_z_performance.htm
]
 * webpage on IBM z/VM Performance Considerations for Linux Guests [
http://www.vm.ibm.com/perf/tips/linuxper.html ]'
 
 The corresponding architecture specific installation documentation should be updated accordingly.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Both
Affects Installer: Yes
Delivery Mechanism: Request Red Hat development assistance
Category:	Installation
Request Type:	Installer - Enhancement from Distributor
d. Upstream Acceptance:	No Code Required
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	no
g. Component Version Target:	n/a

3. Business Case
These changes will improve the installation experience for customers by making the installation
workflow more usable and efficient, which will result in an improvement of the customer satisfaction.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 John Jarvis 2008-12-22 12:10:50 EST
IBM is signed up to test and provide feedback.
Comment 2 IBM Bug Proxy 2009-04-27 13:12:05 EDT
------- Comment From mgrf@de.ibm.com 2009-04-27 13:02 EDT-------
Hello Red Hat, Hi John,
What is the status regarding RHEL 5.4 acceptance for this feature?
Comment 3 John Jarvis 2009-04-27 14:34:01 EDT
This feature is denied for RHEL 5.4 due to a lack of resources.
Comment 4 IBM Bug Proxy 2009-04-28 08:31:34 EDT
------- Comment From gmuelas@de.ibm.com 2009-04-28 08:25 EDT-------
Hello Red Hat,

- if IBM takes over the QA (Test) responsibility for this feature, would you still have not resources to implement it?

- IBM believes that this it is a very interesting feature for the RHEL 5 System z customers, but since to implement this feature, RHEL would need changes in installer and documentation and we already in the 4th minor update, is Red Hat interested in this feature at all for future minor updates in RHEL 5, assuming you
have the resources for future RHEL 5 minor updates?

Thank you!
Gonzalo Muelas Serrano.
Comment 5 John Jarvis 2009-06-11 09:24:38 EDT
Closing as WONTFIX for RHEL 5.4 due to lack of capacity, please feel free to reopen to request this feature for consideration for RHEL 5.5
Comment 6 IBM Bug Proxy 2009-07-15 08:22:32 EDT
------- Comment From mgrf@de.ibm.com 2009-07-15 08:17 EDT-------
Rejected by RH due to lack of resources

Deferring feature request to RHEL 5.5
Comment 7 John Jarvis 2009-07-15 09:28:01 EDT
Reopening and putting on the RHEL 5.5 tracker for consideration for inclusion in that release.
Comment 8 IBM Bug Proxy 2009-07-16 08:20:37 EDT
------- Comment From mgrf@de.ibm.com 2009-07-16 08:10 EDT-------
This request got a new feature BZ for RHEL 5.5 that is

LTC 54805 - RHBZ 511985 [LTC 5.5 FEAT] Adjust Anaconda Swap recommendations to Linux on System z specifics [201680]

Therefore closing this for RHEL 5.4 with "willnotfix" based on Red Hat reject
Comment 9 John Jarvis 2009-07-16 09:59:00 EDT
*** Bug 511985 has been marked as a duplicate of this bug. ***
Comment 10 IBM Bug Proxy 2009-08-03 08:30:45 EDT
------- Comment From mgrf@de.ibm.com 2009-08-03 08:20 EDT-------
*** Bug 54805 has been marked as a duplicate of this bug. ***

------- Comment From mgrf@de.ibm.com 2009-08-03 08:24 EDT-------
As agreed with John:

Re-open old RHEL 5.4 feature to request for inclusion into RHEL 5.5.
That is to have done discussions included in feature request

Note:
The new opened RHEL 5.5 feature BZ get closed
LTC 54805 - RHBZ 511985  [LTC 5.5 FEAT] Adjust Anaconda Swap recommendations to Linux on System z specifics [201680]
Comment 11 IBM Bug Proxy 2009-08-03 08:30:56 EDT
Per agreement with John,

Tracking this feature request with the old RHEL 5.4 request - deferred to 5.5
to have done discussions included. That is
LTC 50345 - RHBZ 475358 ?? [LTC 5.4 FEAT] Adjust Anaconda Swap recommendations to Linux on System z specifics [201680]

Closing this new created request  as DUP

*** This bug has been marked as a duplicate of bug 50345 ***
Comment 12 IBM Bug Proxy 2009-09-04 04:01:23 EDT
------- Comment From mgrf@de.ibm.com 2009-09-04 03:55 EDT-------
There is no IBM code to be submitted for this feature
Comment 13 John Jarvis 2009-10-26 09:25:51 EDT
IBM is signed up to test and provide feedback.
Comment 14 Chris Lumens 2009-10-29 11:45:18 EDT
This bug needs to be broken up into two:  a new one filed against documentation to change that portion, and this one to track the anaconda portion.

For anaconda, can you please provide a simple and straightforward algorithm (in text, pseudocode, whatever) for how anaconda can come up with a recommended minimum and maximum swap amount on s390?
Comment 15 IBM Bug Proxy 2009-10-29 12:30:46 EDT
------- Comment From gmuelas@de.ibm.com 2009-10-29 12:23 EDT-------
Hi Chris,

apparently the doc. part was done in RHEL 5.4 (http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.4/html/Installation_Guide/s2-diskpartrecommend-s390.html) , so the only thing to do is to remove the warning if the swap is small than the memory.

Since as you may read in the documentation, the rules are not so easy and is an "it depends", I suggest to remove all warning regarding swap decision, except for the case where the user does not setup swap at all, in which maybe something like: "You have not configured any swap space, are you sure you want to continue without swap?"

FYI - As far as I recall from last Friday eSDT call, Denise wanted to check with David (or maybe you) about this feature...you might want to sync. with them...

Thank you!
Gonzalo Muelas Serrano.
Comment 16 Brock Organ 2009-12-16 11:12:31 EST
Hi Gonzalo,

In the interest of specificity, can we make the algorithm for s390x swap size:

* 250 Mb of swap allocated regardless of STORAGE size
* no user warning about swap space configuration (unless there is no swap)

Is this acceptable?  

Barring acceptance of this (or other similar specific and deterministic algorithm ... ), I feel like I'm in the tough position where I'd have to make the choice whether to withhold a QA ack for 5.5 (or not) to the feature simply because the algorithm specificity is "it depends". :(

Regards,

Brock
Comment 17 John Jarvis 2009-12-21 16:40:05 EST
We are out of resources to do this for RHEL 5.5, it has been deferred for consideration for RHEL 5.6.  Removing from the 5.5 tracker, adding to the 5.6 tracker.
Comment 18 IBM Bug Proxy 2010-01-13 08:51:15 EST
------- Comment From gmuelas@de.ibm.com 2010-01-13 08:43 EDT-------
Hello Red Hat,

I think since the algorithm is "it dependens" on the workload, what IBM is requesting is even easier:
- Only have a warning dialog when no swap is defined.
- If a swap is defined, no matter how big or small, no warning dialog should appear.

How much swap is defined it is documented in the installation guide (with references to the "it depends" documentation) so that the user should read, and the installer does not need to check for a minimum.

Hopefully is doable...

Thank you for your support,
Gonzalo Muelas Serrano.
Comment 19 David Cantrell 2010-01-13 13:13:08 EST
(In reply to comment #18)
> ------- Comment From gmuelas@de.ibm.com 2010-01-13 08:43 EDT-------
> Hello Red Hat,
> 
> I think since the algorithm is "it dependens" on the workload, what IBM is
> requesting is even easier:
> - Only have a warning dialog when no swap is defined.

We already do this.

> - If a swap is defined, no matter how big or small, no warning dialog should
> appear.
> 
> How much swap is defined it is documented in the installation guide (with
> references to the "it depends" documentation) so that the user should read, and
> the installer does not need to check for a minimum.
> 
> Hopefully is doable...

This is doable...for RHEL 5.6.  This requires changes to the anaconda code and while it's simple, we're past the development window for 5.5.
Comment 21 Chris Lumens 2010-02-17 10:40:43 EST
*** Bug 566197 has been marked as a duplicate of this bug. ***
Comment 22 John Jarvis 2010-03-30 15:01:42 EDT
Removing from 5.6 tracker since the work is being tracked in https://bugzilla.redhat.com/show_bug.cgi?id=475358 and that BZ is already on the 5.6 tracker.
Comment 23 David Cantrell 2010-04-21 10:59:42 EDT
Implementing this first in RHEL 6.0 via bug #466289, then will backport to 5.6.
Comment 26 John Jarvis 2010-07-09 16:58:16 EDT
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 28 Jan Stodola 2010-11-08 09:20:36 EST
Tested with anaconda-11.1.2.216-1, build RHEL5.6-Server-20101029.0.
When no swap is defined - warning message is displayed
When a swap is defined (testing values for swap: 3MB, 32MB, 1500MB), there is no warning message.
Tested in vnc and text mode.

Moving to VERIFIED.
Comment 29 IBM Bug Proxy 2010-11-17 09:41:20 EST
------- Comment From mgrf@de.ibm.com 2010-11-17 09:34 EDT-------
This feature is verified based on RHEL 5.6 beta - set to verified Thx
Comment 30 Ruediger Landmann 2011-01-06 18:10:21 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The swap space required by a system running Red Hat Enterprise Linux 5 
varies according to the role of the system. Previously, anaconda recommended 
that all installations on IBM System z required swap space at least equal to 
the amount of installed system memory. This recommendation could have misled 
users to allocate far more swap space than was required for their purposes. 
Anaconda now warns users only if they have not allocated any swap space at 
all. Users can therefore allocate swap space appropriate to their systems 
without potentially misleading warnings from anaconda.
Comment 32 errata-xmlrpc 2011-01-13 16:52:20 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0030.html

Note You need to log in before you can comment on or make changes to this bug.