Bug 475376 - USB modem locks system when connecting to /dev/ttyUSB0
USB modem locks system when connecting to /dev/ttyUSB0
Product: Fedora
Classification: Fedora
Component: ppp (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-12-08 18:15 EST by Karsten Wade
Modified: 2014-11-09 17:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-12-18 02:13:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Relevant parts of /var/log/messages during modem usage attempt. (6.29 KB, application/octet-stream)
2008-12-08 18:15 EST, Karsten Wade
no flags Details

  None (edit)
Description Karsten Wade 2008-12-08 18:15:49 EST
Created attachment 326228 [details]
Relevant parts of /var/log/messages during modem usage attempt.

Description of problem:

Using a new USB modem (Novatel USB727), I am getting a full system
lock during the connection process.  When F10 came out, this lock
occurred within seconds of clicking on the 'Mobile Broadband'
connection in NetworkManager.  Current versions + a (hopefully)
accurate broadband connection configuration in NM produces one of
these results:

* Almost connects all the way, then fails with no ill effect
* Hard locks the system during pppd connect call.

I am attaching a recent log of this occurring.  The log snippet represents 
just the time when the modem was inserted to the lock-up; after the final
line, the machine hard locked.

I'm picking ppp to file this against as that is the component last contacted
in the log.  The only relevant message from dmesg seems to be this one:

usb 5-2: reset full speed USB device using uhci_hcd and address 3

Version-Release number of selected component (if applicable):


How reproducible:

75%+ ... each attempt does not end in a lock-up, but three out of four
do enough to be reliably broken.
Comment 1 Jiri Skala 2008-12-11 07:22:01 EST
described problem came up with the new modem installation or there were another action starting it?
Comment 2 Karsten Wade 2008-12-12 12:24:00 EST
(In reply to comment #1)
> Hi,
> described problem came up with the new modem installation or there were another
> action starting it?

It seemed to come with the new model installation.

I tried to reproduce under Fedora 9 and didn't get the same effect.  I thought it had locked up before, but I updated the entire system before I tested again, so it's hard to know for certain.  It did end with a 'CHAP authentication' failure.

That failure is about where the lock up occurs in F10, but it seems strange to freeze on an auth failure.

As of updates on Thursday 12 Dec (all but PackageKit updated), the problem still occurs.
Comment 3 Karsten Wade 2008-12-17 14:20:08 EST
I'm adding Dan Williams so he can consider if this is in fact something going on with NetworkManager.

I can reliably lock-up my F10 system, and have been able to lock-up an F9 system a few times, although usually it just fails CHAP auth and kills the connection attempt.

Since I was able to get this to happen in F9 _after_ ppp negotiates the connection to /dev/ttyUSB0, two further ideas come to mind:

* It is NM locking up while managing the connection
* It is bad hardware

Perhaps I should try another dial-up program?  I've never used wvdial but could try.
Comment 4 Dan Williams 2008-12-17 14:46:30 EST
If the machine hardlocks while being used in any way, that is a kernel or driver issue.  Simply shouldn't be happening.  I've noticed that recent F9 (2.6.27-41) sometimes hardlocks when disconnecting my Novatel S720 as well, which to me indicates that something in the kernel PPP or USB stacks changed for the worse.  It's quite hard to reproduce for me because it's so intermittent.
Comment 5 Karsten Wade 2008-12-17 16:00:45 EST
As it happens, I can make the hardlock happen reliably, within three tries each time.  What can I do to figure out where the problem is?

Having it occasionally fall over in F9 is interesting, in that there is a range of kernels I could try.  It is also interesting because when it doesn't hardlock in F9, it also does not connect to the ISP with 'CHAP authentication failed' after NM reports '<info> (ttyUSB0): device state change 5 -> 6'.  (I'm presuming the Verizon how-to content I've found via google is correct about the password and such, but it's probably worth a call to tech support to confirm I have all the actual configs correct.)

Note that by hardlock, I mean completely unresponsive console.  I cannot get in via network because the eth/wlan connections are afaict dropped during the ppp negotiation.  However, the fans run, drives spin, USB modem flashes, and the T60 wifi signal light blinks on/off.

I just tried a series of F9 kernels.  Two (kernel-, kernel- immediately hardlock after the CHAP auth failure.  The third (kernel- actually works, with NM throwing up a password dialog, which I apparently have wrong, so I then get CHAP auth failure and pppd actually exits normally.  I am able to do this repeatedly without a hardlock.

So ... should I move this to be a kernel bug?
Comment 6 Dan Williams 2008-12-17 16:19:40 EST
Yeah, probably.  The best way to test would be sysrq I guess, since it's certainly not a panic (at least for me, no capslock light blinks when the box locks), so it's a deadlock somewhere in kernel-land.
Comment 7 Jiri Skala 2009-10-01 03:35:41 EDT
is there some progress (due to kernel update)? I'll move it to kernel bug if not ...

Comment 8 Karsten Wade 2009-10-02 02:59:26 EDT
The original USB modem is no longer with me; lost in the Universe somewhere.  (I've been connecting with an LG Voyager tethered via USB cable on F10 with no problems.)  I need to get a new USB model soonest, but may not get the same model as before.

If I get that USB modem and am still running F10, then I'll be able to answer yay/nay on this bug.  If any of that doesn't work, then probably we should close it as NOTABUG(?)

Meanwhile, I'll (attempt to) leave it in a needinfo on reporter state.
Comment 9 Bug Zapper 2009-11-18 04:39:21 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 10 Bug Zapper 2009-12-18 02:13:06 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 11 Karsten Wade 2014-06-09 11:29:32 EDT
Looks like there was a needinfo on this for me still, I'm adding this comment to clear that (and stop any future alert emails about this bug.)
Comment 12 Karsten Wade 2014-06-09 11:30:15 EDT
Looks like there was a needinfo on this for me still, I'm adding this comment to clear that (and stop any future alert emails about this bug.)

Note You need to log in before you can comment on or make changes to this bug.