Bug 475379 - ssh fails for member of netgroup with ypbind running.
ssh fails for member of netgroup with ypbind running.
Status: CLOSED DUPLICATE of bug 473073
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 18:45 EST by Aaron Greenwood
Modified: 2008-12-09 03:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 03:20:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Aaron Greenwood 2008-12-08 18:45:42 EST
Description of problem:

If both ypbind and ssh are running then ipname resolution fails for all members of the nis netgroup. Connection by ip number works to any member of the netgroup.  Connections and name resolution works for all ip names and ip numbers outside net group.  Using ssh to connect from any machine in the netgroup results in connection being dropped after you give the password.  As a work around I added all ip numbers and ip names to the /etc/hosts file; which worked with ssh.

Version-Release number of selected component (if applicable):


How reproducible:

If I remove the /etc/hosts file then the problem resumes.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tomas Mraz 2008-12-09 03:20:59 EST

*** This bug has been marked as a duplicate of bug 473073 ***

Note You need to log in before you can comment on or make changes to this bug.