Bug 475391 - Qgis needs rebuild for latest geos update
Qgis needs rebuild for latest geos update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qgis (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Douglas E. Warner
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 20:45 EST by Jon Burgess
Modified: 2008-12-14 03:16 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-14 03:16:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Burgess 2008-12-08 20:45:46 EST
Description of problem:
Updating to the latest geos fails due to qgis dependency on old geos version

Version-Release number of selected component (if applicable):
qgis-0.11.0-3.fc10.x86_64
geos-3.0.1-1.fc10.x86_64 (current)
geos-3.0.3-1.fc10.x86_64 (update)

How reproducible:
every time

Steps to Reproduce:
1. Install F10 release versions of qgis & geos
2. Attempt yum update to latest geos
3.
  
Actual results:
  --> Missing Dependency: libgeos-3.0.1.so()(64bit) is needed by package qgis-0.11.0-3.fc10.x86_64 (installed)

Expected results:


Additional info:
Is libgeos-3.0.1.so actually the right dependency? Surely geos-3.0.3 should be backwards compatible, or is this a packaging bug in geos?
Comment 1 Jon Burgess 2008-12-08 20:54:03 EST
About the library versioning, it looks like the geos folks deliberately declare the C++ API as being unstable and thus force a rebuild against each release:
http://lists.osgeo.org/pipermail/geos-devel/2005-December/001644.html
Comment 2 Fedora Update System 2008-12-09 09:02:36 EST
qgis-0.11.0-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/qgis-0.11.0-4.fc10
Comment 3 Michael Schwendt 2008-12-09 19:32:20 EST
Please do use updates-testing for such updates and ask releng to buildroot override tags, so you can prepare group updates.
Comment 4 Fedora Update System 2008-12-09 23:37:39 EST
qgis-0.11.0-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Alex Lancaster 2008-12-13 18:03:59 EST
In case people are wondering why this broken dep is still present, apparently some bug in koji or bodhi means that although the updates system thinks the package has been pushed to updates (aka "stable"), actually it hasn't appeared on the mirrors in the repodata yet.  A bug with release engineering has been filed:

https://fedorahosted.org/rel-eng/ticket/1136

Re-opening until this is fixed.
Comment 6 Alex Lancaster 2008-12-14 03:16:17 EST
qgis-0.11.0-4.fc10 has now finally been pushed to the repo (yum install qgis works), so closing bug.

Note You need to log in before you can comment on or make changes to this bug.