Bug 475398 - Media Keys do not report events for Microsoft Wireless Laser Keyboard 6000
Media Keys do not report events for Microsoft Wireless Laser Keyboard 6000
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
http://bugzilla.kernel.org/show_bug.c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 21:47 EST by Aaron Clark
Modified: 2009-02-19 18:38 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.27.15-170.2.24.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 18:38:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 11759 None None None Never
Launchpad 281993 None None None Never

  None (edit)
Description Aaron Clark 2008-12-08 21:47:42 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.4) Gecko/2008111217 Fedora/3.0.4-1.fc10 Firefox/3.0.4

None of the media keys (except the 'bookmark' keys numbered 1-5 on the top left of the keyboard) function in X, and none report keycodes in the System->Preferences->Personal->Keyboard Shortcuts application.  

They had previously worked waaay back in kernel-xen-2.6.21, kernel-2.6.24 time (Sorry I can't be more accurate as to when it broke, I jumped from fedora 8 to 10, had NIC problems with RTL8111/8168B so mostly ran the xen kernel).

Hardware specs for the peripherals:
Microsoft Wireless Laser Keyboard 6000 v2.0, model 1074
Microsoft Wireless Desktop Receiver 3.1, model 1028

It appears to be a case of quirks for the Wireless Desktop Receiver breaking a bunch of keys to fix a bunch of other keys.  From the Stable git tree on Kernel.org, the offending patchset appears to be:
http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6-stable.git;a=commit;h=974faac46455076c709a745f546b348017ad18dc

With associated typo fix:
http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6-stable.git;a=commit;h=aaad2b0c757f3e6e02552cb0bdcd91a5ec0d6305

And Microsoft quirks refactoring:
http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6-stable.git;a=commit;h=78a849a682a1d5ee7b7187b08abdc48656326a4e

Reproducible: Always

Steps to Reproduce:
1. Run System->Preferences->Personal->Keyboard Shortcuts (aka gnome-keybinding-properties)
2. Choose a keybinding to change
3. Press any of the media keys (Play/Pause, Forward, Back, Mute, Volume, Home, Documents, Mail, etc)
Actual Results:  
Nothing happens

Expected Results:  
Keycode is bound for the shortcut e.g. 0xc0

There is a Ubuntu bug filed on Launchpad about this same issue (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/281993).  It has an associated patch (http://launchpadlibrarian.net/19501251/patch.keyboard) that apparently fixes things but it appears to be a bit of a kludge by simply reverting out the original quirks changes.
Comment 1 Aaron Clark 2009-01-19 23:21:14 EST
Kernel upstream has added a patch purporting to fix the media keys.  If someone wants to whip up a kernel build with it, I'd be happy to test it out.
Comment 2 Aaron Clark 2009-02-02 22:11:41 EST
The fix appears to have hit Linus' tree the day after 2.6.29-rc3 was tagged.  If one of the Koji builds for f10 has pulled it in, please point me to it and I'll test it out.

The commit revision on Linus' tree is:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=0fb21de0799a985d2da3da14ae5625d724256638
Comment 3 Chuck Ebbert 2009-02-03 16:28:40 EST
Upstream patch is in 2.6.27.14-170.2.13
Comment 4 Aaron Clark 2009-02-04 17:47:28 EST
Thanks Chuck, I'll keep an eye out for it on Koji!
Comment 5 Aaron Clark 2009-02-06 10:38:55 EST
Chuck,

I tried kernel-2.6.27.15-170.2.17.rc1.fc10 last night but got a kernel oops sometime during the boot process and my NIC was broken again (likely related to #460747 and/or #448712).  Something in the desktop was pegging the CPU, so I couldn't test the media keys.  I will try to find time on Sunday to reproduce it and file a bug on the oops.
Comment 6 Aaron Clark 2009-02-13 17:48:07 EST
Chuck,

I installed kernel-2.6.27.15-170.2.24.fc10.x86_64 last night and everything appears happy and functional with it.  The media keys were correctly automatically detected.

As far as I'm concerned it is fixed.  What else needs to be done to help get the bug closed off and the update out to stable?

Note You need to log in before you can comment on or make changes to this bug.