Bug 475432 - gdm leaves "accessibility features can be toggled with keyboard shortcuts" feature on, even when the user has turned it off
gdm leaves "accessibility features can be toggled with keyboard shortcuts" fe...
Status: CLOSED DUPLICATE of bug 445898
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 01:48 EST by nvwarr
Modified: 2015-01-14 18:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 10:54:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nvwarr 2008-12-09 01:48:17 EST
Description of problem:

gdm leaves accessibility options set incorrectly before handing over to window manager. This causes problems with some window managers (e.g. fvwm, icewm) that shows up if the shift key is held down the "slow keys" option is turned on, even though it is off according to gnome-keyboard-properties.

This problem was reported against Fedora 9, but it took so long to figure out which component caused the bug, that I don't think it was ever explicitly reported against gdm. In any case, it still exists in Fedora 10.

It was reported as bug 445898 against Fedora 10 seven months ago.

Version-Release number of selected component (if applicable):

gdm-2.24.0-12.fc10.i386

How reproducible:

Always.

Steps to Reproduce:
1. Log in from gdm-simple-chooser into a window manager like fvwm
2. Hold down shift for about 8 seconds
  
Actual results:

Slow keys comes on without any dialog

Expected results:

Slow keys should not be left on by gdm when the option is turned off for the user.

Additional info:

As gdm-simple-chooser runs under the gdm account, there are no configuration options that a normal user can use to control this "feature". It has to be turned off for the gdm account:

sudo -u gdm gconftool-2 -s /apps/gdm/simple-greeter/settings-manager-plugins/a11y-keyboard/active -t bool false

That command fixes the problem. Then an ordinary user can turn on or off the slow keys option through gnome-keyboard-properties as expected.
Comment 1 Ray Strode [halfline] 2008-12-09 10:54:37 EST
it's settings-daemon that's at fault, not gdm.  settings-daemon should behave better when it gets killed.

*** This bug has been marked as a duplicate of bug 445898 ***

Note You need to log in before you can comment on or make changes to this bug.