Bug 475437 - tor-lsb: error in post install scipt
tor-lsb: error in post install scipt
Status: CLOSED DUPLICATE of bug 375361
Product: Fedora
Classification: Fedora
Component: tor (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 02:41 EST by Tomas Hoger
Modified: 2008-12-09 09:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 08:13:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Hoger 2008-12-09 02:41:31 EST
Description of problem:
While updating tor from tor-lsb-0.1.2.19-1.fc9.x86_64 to tor-lsb-0.2.0.32-1.fc9.x86_64, I got following error (similar issue seems to affect current Rawhide version as well):

/var/tmp/rpm-tmp.28941: line 1: /usr/lib/lsb/install_initd: No such file or directory
error: %post(tor-lsb-0.2.0.32-1.fc9.x86_64) scriptlet failed, exit status 127

Issue is caused by the following snipped in %post:

  %post lsb
  /usr/lib/lsb/install_initd %_initrddir/tor

On x86_64, this symlink is installed in lib64, so possibly something like:

  %_libdir/lsb/install_initd %_initrddir/tor

need to be used instead.


# rpm -ql redhat-lsb | grep install_initd
/usr/lib64/lsb/install_initd
Comment 1 Enrico Scholz 2008-12-09 08:13:09 EST
That's due to broken redhat-lsb packages in F8 + F9.  F10 + rawhide should be fine.

*** This bug has been marked as a duplicate of bug 375361 ***
Comment 2 Tomas Hoger 2008-12-09 09:12:49 EST
Ah, sorry for the extraneous report....

Note You need to log in before you can comment on or make changes to this bug.